Page MenuHomePhabricator

No del/undel links for current version of filearchive lists
Open, LowestPublic

Description

Author: happy.melon.wiki

Description:
If you go to any image page, there are del/undel links in the "file history" section to suppress aspects of the filearchive record. However, there is no link to hide, for instance, the username or upload comment, for the current version of the image.


Version: 1.16.x
Severity: enhancement

Details

Reference
bz20742

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 10:57 PM
bzimport set Reference to bz20742.
bzimport added a subscriber: Unknown Object (MLST).

This would need a schem-change (img_deleted)

Created attachment 8219
schema-change: add img_deleted to image table

The schema-change is not complex (see patch).

attachment bug20742-schema-change.patch ignored as obsolete

Comment on attachment 8219
schema-change: add img_deleted to image table

patch is old and maybe a better way exist with the new updater.

[Removing RESOLVED LATER as discussed in http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html . Reopening and setting priority to "Lowest". For future reference, please use either RESOLVED WONTFIX (for issues that will not be fixed), or simply set lowest priority. Thanks a lot!]

  • Bug 49590 has been marked as a duplicate of this bug. ***