Page MenuHomePhabricator

[wmf.14-regression] issues with saving edits to Flow board description
Closed, ResolvedPublic

Description

The bug exists in cawiki (wmf.14) and testwiki (wmf.15). The user talk pages to try: https://test.wikipedia.org/wiki/User_talk:Zilant32 or https://test.wikipedia.org/wiki/User_talk:Zilant17

  1. Add text to Flow board description. Click on 'Publish description' - the following errors will be displayed in the Console and the action of saving changes seems to be unfinished:
Query.Deferred exception: Cannot read property '$content' of undefined TypeError: Cannot read property '$content' of undefined
    at mwFlowUiBoardDescriptionWidget.oo.EventEmitter.emit

jQuery.Deferred exception: Cannot read property 'error' of undefined TypeError: Cannot read property 'error' of undefined
  1. Click 'Cancel' and confirm in the popup that edits should be dismissed - the edits would be, in fact, saved.

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Jul 23, 11:29 PM

Change 525186 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@master] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525186

This turned out to be a regression dating back to late April: rEFLW939d956727ed: Autosave comments

Catrope claimed this task.Wed, Jul 24, 1:29 AM
Catrope edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
Catrope moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 525186 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525186

Etonkovidova closed this task as Resolved.Wed, Jul 24, 5:43 PM

Checked in betalabs - the issue is fixed. Added to the to post-deployment checklist.

Change 525331 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.15] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525331

Change 525332 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.14] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525332

Change 525332 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.14] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525332

Change 525331 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.34.0-wmf.15] Follow-up Ie1d16ff3c5a0: fix JS error when saving board description

https://gerrit.wikimedia.org/r/525331

Mentioned in SAL (#wikimedia-operations) [2019-07-24T23:42:38Z] <catrope@deploy1001> Synchronized php-1.34.0-wmf.14/extensions/Flow: Fix JS error when saving Flow board descriptions (T228818) (duration: 01m 03s)

Mentioned in SAL (#wikimedia-operations) [2019-07-24T23:43:40Z] <catrope@deploy1001> Synchronized php-1.34.0-wmf.15/extensions/Flow: Fix JS error when saving Flow board descriptions (T228818) (duration: 01m 01s)