Page MenuHomePhabricator

Translation issues "Next Issue" button doesn't work: Uncaught TypeError: Cannot read property 'id' of undefined
Closed, ResolvedPublic

Description

I see this error from time to time, not exactly sure how to replicate it.
Steps:

  1. create a new translation
  2. translate a few paragraphs using an MT engine
  3. when you see that you have more than 2 issues on the issue list, , click the "next issue" (right arrow button) on the issues panel
  • the number of the current issue doesn't change and there's an error in the console

video of the issue

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterFix navigation problem when last issue inside a card gets resolved
mediawiki/extensions/ContentTranslation : masterFix navigating multiple issues per node
mediawiki/extensions/ContentTranslation : masterInitialize issue count label when issue tracking tool is populated

Event Timeline

Jpita created this task.Jul 29 2019, 2:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2019, 2:22 PM
Pginer-WMF triaged this task as Normal priority.Jul 29 2019, 3:29 PM
Aklapper renamed this task from Translation issues "Next Issue" button doesn't work and throws console error to Translation issues "Next Issue" button doesn't work: Uncaught TypeError: Cannot read property 'id' of undefined.Jul 31 2019, 12:51 AM

Change 531350 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Initialize issue count label when issue tracking tool is populated

https://gerrit.wikimedia.org/r/531350

Change 531462 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix navigating multiple issues per node

https://gerrit.wikimedia.org/r/531462

Change 531350 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Initialize issue count label when issue tracking tool is populated

https://gerrit.wikimedia.org/r/531350

Change 531462 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix navigating multiple issues per node

https://gerrit.wikimedia.org/r/531462

There seems to be some edge cases still, outside the scope of this report. For example, focusing a section with missing block template.

Steps to reproduce Uncaught TypeError: Cannot read property 'id' of undefined found at T226247#5437901.

Change 533307 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix navigation problem when last issue inside a card gets resolved

https://gerrit.wikimedia.org/r/533307

Change 533307 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix navigation problem when last issue inside a card gets resolved

https://gerrit.wikimedia.org/r/533307

was able to reproduce the error another 2 times but don't know the exact steps, there's another edge case out there that is not protected.
if @Petar.petkovic can't find it looking at the code, let's move this along and if I manage to find the exact steps I'll reopen it.

Jpita closed this task as Resolved.Sep 11 2019, 9:38 PM