Page MenuHomePhabricator

Update Endowment automatic thank you email
Closed, ResolvedPublic

Description

Here's the text we'd like to use for this year's automatic Thank You email. (Note: may need some formatting for the automatic fields -- [NAME], [GIFTAMOUNT], and the donation #, date and amount in the footer. Not sure what the proper syntax is!)

SL: Your donation ensures the future of Wikipedia. Thank you.

Dear [NAME],

I spent a lot of time thinking about how to express my gratitude for your $[GIFTAMOUNT] gift to the Wikimedia Endowment. You did something that so few people do – made a gift – and it’s important I tell you how special that is to us.

But in the end, I realized the best thing I could do is just say it: thanks, [NAME], from all of us at Wikipedia. Thank you for ensuring the future of free knowledge.

Today, thanks to the support of millions of volunteer editors and donors, you can wander Wikipedia for hours. With more than 50 million articles, Wikipedia can answer almost any question, and take you places you’ve never been. We started the Wikimedia Endowment to make sure future generations have access to Wikipedia like we do today, for years to come.

Your donation ensures that new generations will have this free gift of knowledge available at the touch of a button. There is no greater legacy you can leave to the future than knowledge of the present and the past.

The essential story of Wikipedia is the story of an individual, like you, giving a little bit of themselves to keep the doors of discovery open. Wikipedia will continue to evolve, grow, and meet new challenges because of because of generosity just like yours.

You helped us build this. And I'm committed to making sure Wikipedia is here for the long-term, for you.

[NAME], thank you for making sure Wikipedia has a bright future.

With gratitude,
Jimmy Wales
Wikipedia Founder

Many employers will generously match employee contributions: please check with your employer to see if they have a corporate matching gift program.

For your records: Your donation, number [XXX], on [DATE] was $ [GIFTAMOUNT].

This letter may serve as a record of your donation. No goods or services were provided, in whole or in part, for this contribution. Our postal address is: Wikimedia Foundation, Inc., P.O. Box 98204, Washington, DC 20090-8204, USA. U.S. tax-exempt number: 20-0049703

If you do not wish to receive any future fundraising emails from the Wikimedia Endowment or the Wikimedia Foundation, you can unsubscribe instantly. Please note we will still send you receipts, like this one, for future donations.

Event Timeline

kaythaney created this task.Sep 5 2019, 4:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2019, 4:16 PM
kaythaney updated the task description. (Show Details)Sep 5 2019, 4:17 PM

I'll prepare a patch for this, as a chance to test the new direct git method.

Change 535187 had a related patch set uploaded (by Pcoombe; owner: Pcoombe):
[wikimedia/fundraising/crm@master] Update endowment thank you email

https://gerrit.wikimedia.org/r/535187

Change 535193 had a related patch set uploaded (by Ejegg; owner: Ejegg):
[wikimedia/fundraising/crm@master] Fix endowment TY test

https://gerrit.wikimedia.org/r/535193

Change 535193 merged by jenkins-bot:
[wikimedia/fundraising/crm@master] Fix endowment TY test

https://gerrit.wikimedia.org/r/535193

Pcoombe added subscribers: jrobell, DStrine.

An update on this, it's in review but testing is blocked by a bug we found (T232504: 500 error when testing Endowment thank you emails in Civi). I believe Elliott is working on fixing that this sprint.

@jrobell this bug is blocking @Pcoombe from previewing edits: T232504

Someone is working on it. We hope to have this unblocked soon.

@kaythaney I just sent you a couple of test emails, one with a named donor and one anonymous. Please can you check these and confirm if they look correct?

@Pcoombe confirmed! look good!

Yeay! :) Thank you @Pcoombe and @DStrine and team for your work on this! So we can close this task then? @kaythaney do you have what you need?

@jrobell No, this was just a test from the staging environment. It still needs to be deployed to production which will make it the email donors actually get.

Gotcha! Thank you for clarifying, Peter!

Change 535187 merged by jenkins-bot:
[wikimedia/fundraising/crm@master] Update endowment thank you email

https://gerrit.wikimedia.org/r/535187

Ejegg added a subscriber: Ejegg.Thu, Sep 19, 6:26 PM

OK, this is deployed to production

Pcoombe closed this task as Resolved.Thu, Sep 19, 8:28 PM

Just made a test endowment donation and confirmed I get the new email. Thanks!