Page MenuHomePhabricator

New iframe failure issues (confirmed modern browsers)
Closed, ResolvedPublic2 Estimate Story Points

Description

From today's banner test and emails we've added 4 iframe errors to the triage spreadsheet, from a range of browsers. There are probably more already in the queue, and Big English is just getting underway.

I'm not sure if this is similar to T112181: iframe not appearing for some people (confirmed modern browsers) but I will continue to triage.

If there are any adjustments we can make to the form to reduce iframe failures that would be great, but in addition to that, I would like help compiling a comprehensive list of suggestions to offer donors who get stuck here.

So far we have:

  • making sure browser is up to date (old Safari and IE are known compatibility issues)
  • enabling Javsacript
  • disabling third party script blockers
  • checking to see if a work network firewall is blocking the form

What else can we suggest to help these people donate? Is there data beyond browser/OS, mobile or desktop, URL, and browser add-ons that we can ask donors to provide to help understand this problem?

Details

Related Gerrit Patches:
mediawiki/extensions/DonationInterface : masterClear payment submethod radios on validation fail

Event Timeline

MBeat33 created this task.Oct 9 2019, 8:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 9 2019, 8:22 PM
MBeat33 added a comment.EditedOct 18 2019, 1:51 PM

@krobinson forwarded a good suggestion:

It's possible that some of these iframe errors are caused by how the form behaves if you select the card type before entering name and address. The excellent donor in #625769 got different results from different browsers:

In MacBook Air with MacOS X 10.14.6, Safari Version 13.0.1 (14608.2.11.1.11), Chrome Version 77.0.3865.120 (Build officiel) (64 bits) or FireFox v. 63.0.1 (64 bits):

after you've filled in the name and address, the card type chosen before entering the details is sticky, and does not refresh.

In PC w/Chrome:

after you've filled in the name and address, the card type chosen before entering the details is not sticky, and asks you to select a card again.

Some of these cases may be donors not knowing that they need to click a card type that is not their card type, in order to be able to re-select their card type to open the iframe?

Is it possible to make all browsers behave the same way Chrome does on a PC (once you've gone back and entered personal details after receiving the 'red fields' error, the select card type option is automatically reset)?

XenoRyet claimed this task.Oct 21 2019, 5:55 PM
XenoRyet moved this task from Backlog to Doing on the Fundraising Sprint Usual Subscripts board.

Change 545955 had a related patch set uploaded (by XenoRyet; owner: XenoRyet):
[mediawiki/extensions/DonationInterface@master] Clear payment submethod radios on validation fail

https://gerrit.wikimedia.org/r/545955

XenoRyet set the point value for this task to 2.

Wrong task, undoing comment.

XenoRyet closed this task as Resolved.Oct 31 2019, 6:44 PM
XenoRyet reopened this task as Open.Oct 31 2019, 6:57 PM
XenoRyet moved this task from Deployed to Doing on the Fundraising Sprint Visual Basic Instinct board.
XenoRyet moved this task from Doing to Review on the Fundraising Sprint Visual Basic Instinct board.

Change 545955 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Clear payment submethod radios on validation fail

https://gerrit.wikimedia.org/r/545955

XenoRyet added a comment.EditedNov 7 2019, 11:11 PM

Ok, I've deployed a change that addresses the different behavior on MacOS browsers. Everything should work the same across all browsers now.

Beyond that, I haven't found anything specifically actionable, and the list of suggestions for retry still seems fairly complete. One possible addition is that we do sometimes get plain old timeouts from Ingenico, so simply trying again might be a solution. I assume most donors will have done that themselves by the time the contact donor services, but I thought I'd mention it anyway.

XenoRyet closed this task as Resolved.Nov 12 2019, 9:11 PM