Page MenuHomePhabricator

Changing active namespaces of VisualEditor on VEC Wikipedia
Closed, ResolvedPublic

Description

Hi, should it be possible to activate VisualEditor on all our namespaces present in VEC Wikipedia? Let me know. Thanks

Event Timeline

Vajotwo created this task.Apr 16 2020, 5:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 16 2020, 5:35 PM
QEDK added a subscriber: QEDK.EditedApr 17 2020, 6:54 AM

@Vajotwo link to community discussions please.

edit: Well I found it myself. Right now only two editors have supported the proposal which seems way too few, the wiki has 55 active editors and the noticeboard has 6 active participants, even a few more would be good before going forward with this. Please publicize the proposal on your wiki.

QEDK claimed this task.Apr 17 2020, 5:19 PM
QEDK triaged this task as Low priority.
QEDK edited projects, added Community-consensus-needed; removed VisualEditor.
QEDK moved this task from Inbox to In Progress on the User-QEDK board.Apr 22 2020, 9:57 AM

Change 592427 had a related patch set uploaded (by QEDK; owner: QEDK):
[operations/mediawiki-config@master] Enable VisualEditor for more namespaces on vecwiki

https://gerrit.wikimedia.org/r/592427

@Jdforrester-WMF The project request seems to be for all namespaces but no project has it enabled for Talk pages (and I believe the VE team did not want it?) What about this particular case?
The discussion seems to mention Article talk and User talk specifically from what I can figure.

If it were possible we would like to introduce the VisualEditor in each of our individual namespaces regardless of its specific function. Is it possible that you know?

QEDK added a subscriber: Catrope.Apr 25 2020, 6:48 AM

@Vajotwo It is possible but it has not been done before for some reason, since I'm not on the deployment side of things, I'm not aware why, maybe @Catrope / Jdforrestor will be able to clarify further, if the VE team okays it, I'm sure it'll be enabled for most namespaces (still not all, as there's templates, MediaWiki, so on..)

QEDK raised the priority of this task from Low to Medium.Apr 25 2020, 8:58 AM

The issue is VisualEditor doesn't support discussions. Enabling in a discussion place would make communities submit a lot of bug reports that are actually not bugs - rather misusing a tool to do something it was not created to do. QEDK's patch looks good to me.

Ok I understand perfectly. Then we rely on you. You decide where to activate it exactly. No problem for us. Thanks

QEDK moved this task from Code Review to Blocked on the User-QEDK board.Apr 30 2020, 6:56 PM

Change 592427 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable VisualEditor for more namespaces on vecwiki

https://gerrit.wikimedia.org/r/592427

Mentioned in SAL (#wikimedia-operations) [2020-05-04T11:18:24Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: cc94ea7: Enable VisualEditor for more namespaces on vecwiki (T250419) (duration: 01m 07s)

QEDK closed this task as Resolved.May 4 2020, 11:36 AM
QEDK removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 4 2020, 11:36 AM