Page MenuHomePhabricator

return of the infamous bug that displays QID instead of labels
Closed, DuplicatePublic

Description

Hi,

yesterday, I noticed it on Commons https://commons.wikimedia.org/wiki/File:Barbaud-Koch_Marthe-Elisabeth_Fleurs.jpg , and it was also reported in Bibliographie template on frwiki and frwikiversity...

thanks for your help.

sorry if this notification is a duplicate, I'm never able to find the right report on Phabricator

Event Timeline

Hsarrazin created this task.May 7 2020, 5:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 7 2020, 5:34 PM

Hi @Hsarrazin, thanks for taking the time to report this! I go to the link and I am not sure where to see some "QID". Could you elaborate please? Ideally, a clear list of exact steps to reproduce the situation, what happens (and where exactly), and what you expected to happen instead are very welcome. Thanks again!

Hi @Aklapper go on any page on any Wikimedia projects, you'll see that some label are not retrieve and the Wikidata Q identifier (or P identifier) is displayed instead.

It happened before (can't find it back).

It's maybe/probaly related to T252079.

@Aklapper Hi, if I look a radom page, like this one it appear on all pages who use Wikidata models. I just added a picture how it appear on mu screen.

I don't see this problem when I choose « English » but I see it in French and Spanish.

Hsarrazin added a comment.EditedMay 7 2020, 6:54 PM

Sorry, I did not remember that bug was language sensitive... mine is French. generally, in English, the bug does not appear...

should have put a capture... on some values, that should be displayed from wd, the QID appears insted of the label of the item used...


for example, in the title bar, the name of the painter is replaced by Q17306537, and the object type is Q3305213 (instead of "peinture/painting")

Can someone add appropiate project tags?

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMay 7 2020, 8:31 PM