Page MenuHomePhabricator

Fatal RevisionAccessException: Not an available content version. (pagebundle API)
Closed, DuplicatePublicPRODUCTION ERROR

Description

Error

MediaWiki version: 1.36.0-wmf.5

message
MediaWiki\Revision\RevisionAccessException: Not an available content version.
exception.trace
#0 /srv/mediawiki/php-1.36.0-wmf.5/vendor/wikimedia/parsoid/extension/src/Rest/Handler/ParsoidHandler.php(352): MWParsoid\Config\PageConfigFactory->create(Title, User, integer, NULL, NULL, array)
#1 /srv/mediawiki/php-1.36.0-wmf.5/vendor/wikimedia/parsoid/extension/src/Rest/Handler/TransformHandler.php(138): MWParsoid\Rest\Handler\ParsoidHandler->createPageConfig(Title, integer, NULL)
#2 /srv/mediawiki/php-1.36.0-wmf.5/includes/Rest/Router.php(365): MWParsoid\Rest\Handler\TransformHandler->execute()
#3 /srv/mediawiki/php-1.36.0-wmf.5/includes/Rest/Router.php(320): MediaWiki\Rest\Router->executeHandler(MWParsoid\Rest\Handler\TransformHandler)
#4 /srv/mediawiki/php-1.36.0-wmf.5/includes/Rest/EntryPoint.php(144): MediaWiki\Rest\Router->execute(MediaWiki\Rest\RequestFromGlobals)
#5 /srv/mediawiki/php-1.36.0-wmf.5/includes/Rest/EntryPoint.php(110): MediaWiki\Rest\EntryPoint->execute()
#6 /srv/mediawiki/php-1.36.0-wmf.5/rest.php(31): MediaWiki\Rest\EntryPoint::main()
#7 /srv/mediawiki/w/rest.php(3): require(string)
#8 {main}

Impact

Notes

Details

Request ID
6867bce0-e7b4-11ea-87bf-d5477a827a92
Request URL
https://en.wikipedia.org/w/rest.php/en.wikipedia.org/v3/transform/pagebundle/to/wikitext/Draft%3AThierry_Malleret/975053200

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 26 2020, 6:19 PM
ssastry closed this task as Declined.Aug 27 2020, 4:00 PM
ssastry added a subscriber: ssastry.

Nothing to do here. It is just a report that the revision in question has been hidden and is not available. The URL indicates it is a draft namespace page and they do get deleted / hidden. https://en.wikipedia.org/wiki/Draft:Thierry_Malleret?oldid=975053200 confirms that.

Mentioned in SAL (#wikimedia-operations) [2020-08-27T19:57:20Z] <marxarelli> 1.36.0-wmf.6 promoted to all wikis (T257974). new errors appear to be related to T261345 but are known since 1.36.0-wmf.5

Krinkle changed the task status from Declined to Resolved.Tue, Sep 22, 3:44 PM
Krinkle reopened this task as Open.EditedTue, Sep 22, 4:04 PM
Krinkle added a subscriber: Krinkle.

This is a fatal crash from a service deployed in production.

It's fine if what the request is asking for doesn't, can't, or shoudn't exist. That's what warnings messages and e.g. HTTP 4xx are for.

Fatal MediaWiki\Revision\RevisionAccessException: Not an available content version.
…
#6 /srv/mediawiki/php-1.36.0-wmf.9/includes/Rest/EntryPoint.php(144): MediaWiki\Rest\Router->execute(MediaWiki\Rest\RequestFromGlobals)
#7 /srv/mediawiki/php-1.36.0-wmf.9/includes/Rest/EntryPoint.php(110): MediaWiki\Rest\EntryPoint->execute()
#8 /srv/mediawiki/php-1.36.0-wmf.9/rest.php(31): MediaWiki\Rest\EntryPoint::main()
#9 /srv/mediawiki/w/rest.php(3): require(string)
#10 {main}

For MediaWiki developers that monitor Rest\EntryPoint or RevisionStore, this crash is showing on their feeds.
For MediaWiki deployers that monitor app servers overall, this crash can be triggered by users at random and abort their deployment if it spikes at the wrong time.

And if this fatal is producing a HTTP 5xx response (I think, but not sure) then for SRE monitoring the server health, this would also look like a service in unhealthy state and may trigger alarms at odd hours any day.

Krinkle renamed this task from Not an available content version. to Fatal RevisionAccessException: Not an available content version. (pagebundle API).Tue, Sep 22, 4:04 PM
Krinkle triaged this task as High priority.
Krinkle updated the task description. (Show Details)
Krinkle edited Stack Trace. (Show Details)

This should have been resolved as part of last week's train ( https://gerrit.wikimedia.org/r/c/mediawiki/services/parsoid/+/626724/ ). I am going to close this as a dupe of the task I had tagged there.