Page MenuHomePhabricator

Citoid says "We couldn't make a citation for you" for some sites on Arabic Wikipedia
Closed, ResolvedPublic

Description

Hello per users complaints that they facing Citoid-citefromiddialog-use-general-error-message with a lot of websites on Arabic Wikipedia since 3 days.

We couldn't make a citation for you. You can create one manually using the "[citoid-citefromiddialog-mode-manual]" tab above.

Example:

Also, I noticed that the error message not substituted, as it appear on the Arabic interface like this:

لم نتمكن من صنع الاقتباس لك، يمكنك إنشاء واحد يدويا باستخدام التبويب "⧼citoid-citefromiddialog-mode-manual⧽" أعلاه.

There's no problem on MediaWiki:Citoid-citefromiddialog-use-general-error-message/ar

Event Timeline

alaa created this task.Sep 5 2020, 11:09 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2020, 11:09 AM
Mvolz added a subscriber: Mvolz.Sep 5 2020, 8:27 PM

If you look at https://ar.m.wikipedia.org/wiki/%D8%AE%D8%A7%D8%B5:%D8%AA%D8%A7%D8%B1%D9%8A%D8%AE/%D9%82%D8%A7%D9%84%D8%A8:%D8%A7%D8%B3%D8%AA%D8%B4%D9%87%D8%A7%D8%AF_%D9%88%D9%8A%D8%A8/%D8%B4%D8%B1%D8%AD someone has deleted all the template data. That needs to be reverted on all the templates where it has been done as citoid will not work without template data.

alaa added a comment.Sep 6 2020, 8:45 AM

I've reverted these two changes with my work account Mvolz (WMF), but another user will need to approve the change since it's pending review.

Thanks @Mvolz. I approved all of them. And I can confirmed that Automatic cite works again. (I'll ask users with complaints to try it, then we can close this task).

What about the error message not substituted ?

Mvolz added a comment.Sep 6 2020, 8:57 AM
In T262129#6438601, @alanajjar wrote:

I've reverted these two changes with my work account Mvolz (WMF), but another user will need to approve the change since it's pending review.

Thanks @Mvolz. I approved all of them. And I can confirmed that Automatic cite works again. (I'll ask users with complaints to try it, then we can close this task).

What about the error message not substituted ?

citoid-citefromiddialog-mode-manual is the wrong message, I think... we refractored it. T219512. Looks like it didn't get retranslated with the right message name?

Mvolz added a comment.Sep 6 2020, 9:01 AM
In T262129#6438601, @alanajjar wrote:

I've reverted these two changes with my work account Mvolz (WMF), but another user will need to approve the change since it's pending review.

Thanks @Mvolz. I approved all of them. And I can confirmed that Automatic cite works again. (I'll ask users with complaints to try it, then we can close this task).

What about the error message not substituted ?

citoid-citefromiddialog-mode-manual is the wrong message, I think... we refractored it. T219512. Looks like it didn't get retranslated with the right message name?

Yup, this should be citoid-citoiddialog-mode-manual instead.

https://translatewiki.net/w/i.php?title=Special:Translate&showMessage=citoid-citoiddialog-use-general-error-message&group=ext-citoid&language=ar&filter=&optional=1&action=translate needs to be fixed to use the correct dialog name, if you have an account on translatewiki?

Mvolz added a comment.Sep 6 2020, 9:06 AM
In T262129#6438601, @alanajjar wrote:

I've reverted these two changes with my work account Mvolz (WMF), but another user will need to approve the change since it's pending review.

Thanks @Mvolz. I approved all of them. And I can confirmed that Automatic cite works again. (I'll ask users with complaints to try it, then we can close this task).

What about the error message not substituted ?

citoid-citefromiddialog-mode-manual is the wrong message, I think... we refractored it. T219512. Looks like it didn't get retranslated with the right message name?

Yup, this should be citoid-citoiddialog-mode-manual instead.

https://translatewiki.net/w/i.php?title=Special:Translate&showMessage=citoid-citoiddialog-use-general-error-message&group=ext-citoid&language=ar&filter=&optional=1&action=translate needs to be fixed to use the correct dialog name, if you have an account on translatewiki?

I tried doing it myself, hopefully I didn't break it. :)

alaa added a comment.EditedSep 6 2020, 9:57 AM

I tried doing it myself, hopefully I didn't break it. :)

Thanks a lot @Mvolz, you did it well!

I'll ask users with complaints to try it, then we can close this task

Confirmed.

alaa closed this task as Resolved.Sep 6 2020, 9:58 AM
alaa assigned this task to Mvolz.
alaa awarded a token.
alaa added a comment.Sep 9 2020, 5:25 PM

Hello @Mvolz, there's a question about the same point that when you try to automatic generate cite in arwiki it's not give the same result on enwiki, for example if you try this link:

In arwiki:
Ian; Burns, Ian R. (1979). African Boundaries: A Legal and Diplomatic Encyclopaedia (باللغة الإنجليزية). C. Hurst. ISBN 978-0-903983-87-7.

In enwiki:
Brownlie, Ian; Burns, Ian R. (1979). African Boundaries: A Legal and Diplomatic Encyclopaedia. C. Hurst. ISBN 978-0-903983-87-7.