Page MenuHomePhabricator

Suggested edits activation: JavaScript error in updatePager
Closed, ResolvedPublicBUG REPORT

Description

I came across this while investigating the note about activation in T263040

There is a JavaScript error in updatePager because of this code:

mw.config.get( 'wgGEHomepageModuleActionData-suggested-edits' ).taskCount

In the context of activating the module, this data is not yet present. It only exists after the task has been rendered on the server side when the module is activated.

Event Timeline

kostajh created this task.Oct 30 2020, 12:37 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 30 2020, 12:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 637688 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Export task count from start editing dialog

https://gerrit.wikimedia.org/r/637688

kostajh changed the subtype of this task from "Task" to "Bug Report".
kostajh moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 637688 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Export task count from start editing dialog

https://gerrit.wikimedia.org/r/637688

Change 639501 had a related patch set uploaded (by Gergő Tisza; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.16] Suggested edits: Export task count from start editing dialog

https://gerrit.wikimedia.org/r/639501

Change 639501 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.16] Suggested edits: Export task count from start editing dialog

https://gerrit.wikimedia.org/r/639501

Mentioned in SAL (#wikimedia-operations) [2020-11-05T19:44:38Z] <urbanecm@deploy1001> Synchronized php-1.36.0-wmf.16/extensions/GrowthExperiments/modules/homepage/: 81cb1c7b141d49d7fc931fdc13ffd1b48b3a25ab: Suggested edits: Export task count from start editing dialog (T266868; T263040) (duration: 01m 07s)

Etonkovidova added a subscriber: Etonkovidova.EditedFri, Nov 6, 1:47 AM

The error is not present anymore, however below is the issue that happens consistently when SE is activated.

@kostajh - the cases below might not be related to the issues that reported in this task.If so, let me know if they are worth filing - the scope of the first one is quite limited and the second one cannot be reproduced reliably.

  • The counter in the topics/filer overlay displays 0 count (e.g. for cswiki betalabs 'Oceania' +Add links between articles combination), but after 'Done' is clicked the number of fetched tasks is different from 0.

  • Another case "No more suggestions" displayed while the counter says otherwise- encountered twice but not reproducible.

@Etonkovidova yes the first one is worth its own issue, thank you.

The second one would be important to fix if we can figure out how to reproduce it.

Etonkovidova closed this task as Resolved.EditedFri, Nov 6, 6:34 PM

@Etonkovidova yes the first one is worth its own issue, thank you.

The second one would be important to fix if we can figure out how to reproduce it.

Thanks, @kostajh. After more testing, the issues mentioned in my comment above seem to be transient, related to some infrastructural deficiencies in betalabs. Since they are not reproducible anymore - no follow ups are needed.
(edited) Just to be thorough - I filed T266868: Suggested edits activation: JavaScript error in updatePager - still seems to me as an edge case.