Page MenuHomePhabricator

Resource loader: incorrect input to makeList()
Closed, ResolvedPublic

Description

Periodically seen on TWN:

/w/load.php?debug=false&lang=en&modules=site&only=scripts&skin=modern&version=1970-01-01T00%3A00%3A00Z: Exception: DatabaseBase::makeList: empty input

Stack trace:
#2 /www/w/includes/ResourceLoader.php(75): DatabaseBase->select('module_deps', Array, Array, 'ResourceLoader:...')
#3 /www/w/includes/ResourceLoader.php(294): ResourceLoader::preloadModuleInfo(Array, Object(ResourceLoaderContext))
#4 /www/w/load.php(48): ResourceLoader::respond(Object(ResourceLoaderContext))

All such exceptions I've seen happen with the Modern skin.


Version: 1.17.x
Severity: major

Details

Reference
bz25338

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:19 PM
bzimport set Reference to bz25338.
MaxSem created this task.Sep 27 2010, 2:57 PM

The crucial point here seems to be that the request really contains & instead of &.

MaxSem added a comment.Oct 1 2010, 7:42 PM

[19:44:20] <MaxSem> Nikerabbit, can you check server logs if their user agents are the same?
[19:46:24] <+Nikerabbit> MaxSem: firefox
[19:46:29] <MaxSem> ugh
[19:46:54] *rakkaus* [01-Oct-2010 15:46:48] /w/load.php?debug=false&amp;lang=pt-br&amp;modules=translate-css&amp;only=styles&amp;skin=modern&amp;version=20100909T150640Z: Exception: DatabaseBase::makeList: empty input
[19:47:07] <+Nikerabbit> MaxSem: referer is http://translatewiki.net/w/i.php?title=Special%3ATranslate&task=untranslated&group=ext-0-wikimedia&language=rue&limit=1000
[19:47:31] <+Nikerabbit> okay that one was ie 6.0
[19:47:41] <MaxSem> every page seems to generate this very link
[19:47:55] <+Nikerabbit> referer http://translatewiki.net/wiki/Portal:Th
[20:35:56] <MaxSem> I think I can fix this bug, but I would like to narrow down the cause of such broken requests
[20:37:23] <+Nikerabbit> MaxSem: broken clients most likely
[20:37:36] <MaxSem> FF is broken?
[20:37:39] MaxSem doubts
[20:38:05] <+Nikerabbit> can't think of any other good explanation
[20:38:34] <MaxSem> and this happens only with modern skin
[20:48:48] <+Nikerabbit> MaxSem: are you sure?
[20:48:58] <+Nikerabbit> it's the default skin
[20:54:11] <MaxSem> http://translatewiki.net/wiki/Special:UserOptionStats/skin
[20:54:21] <MaxSem> it's popular but not universally used
[21:01:10] <MaxSem> all such errors I've found in my IRC logs are for modern
[21:01:50] <MaxSem> mhm
[21:04:50] <MaxSem> I vaguely recall I had problems with css/js not loading some time before. not sure if they disappeared after I switched from modern to vector
[21:05:04] <MaxSem> could be due to this bug
[21:05:49] <+Nikerabbit> I doubt that, we've had many other problems too

I've went ahead and plugged this hole in r74139.