Page MenuHomePhabricator

ZHWP cannot open with Internet Explorer under Windows XP
Closed, ResolvedPublic

Description

IE8 cannot open zhwp any page. Some user report this few hours ago. The user can view other wikis but not zhwp. This bug does not happen to user using non-IE browser such as Firefox.


Version: unspecified
Severity: normal
OS: Windows XP

Details

Reference
bz27677

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:32 PM
bzimport set Reference to bz27677.
bzimport added a subscriber: Unknown Object (MLST).

Looks and seems to work fine for me...

Can you give some more information, screenshots, etc?

Do you have any userscripts or enabled gadgets?

(In reply to comment #1)

Looks and seems to work fine for me...
Can you give some more information, screenshots, etc?

Screenshots cannot be given due the user are unable to go into the website. While I am trying to view RC page, res://ieframe.dll/acr_error.htm#wikipedia.org,http://zh.wikipedia.org/wiki/Special:%E6%9C%80%E8%BF%91%E6%9B%B4%E6%94%B9 display. (Use IE to view this page...)

(In reply to comment #2)

Do you have any userscripts or enabled gadgets?

It is in logged out status.

Created attachment 8204
Looks fine for me logged out in IE8

Attached:

Created attachment 8205
Screenshot

Reproduceable for me with IE8/XP on zh:, works fine on en: - do we see the same error? Note that SysFader is a part of nVidia drivers. Will try to upgrade drivers now.

Attached:

The page I received

I received the page which I attached.

Attached:

Can you translate the error message you are getting please?

Also, what version of windows?

I also experienced.

Once the page is displayed.
Before operating something, that tab will crash.
The browser tries to recover. And then displays an error message.

State was not logged.

(In reply to comment #7)

Can you translate the error message you are getting please?
Also, what version of windows?

Win XP. Just type the following url in your IE and you can see the translation.

res://ieframe.dll/acr_error.htm#wikipedia.org,http://zh.wikipedia.org/wiki/Special:%E6%9C%80%E8%BF%91%E6%9B%B4%E6%94%B9

(Note that is not only the http part but start with res://)

Also, someone report to me that he can view Wikipedia using https://secure.wikipedia.org/ but cannot view Wikipedia using http://zh.wikipedia.org/

PhiLiP.NPC wrote:

What page do you visit? And have you tried to visit zhwiki when you are logged out? I can't reproduce your problem.

Seems only apply to the user:

  • Using IE8
  • Using Windows XP

Changed the bug summary.

(In reply to comment #11)

What page do you visit? And have you tried to visit zhwiki when you are logged
out? I can't reproduce your problem.

It is in logged out status. Someone just visit zhwp mainpage and happen this bug, and me happen this bug on RC. Remember, the data I got is only apply to Win XP user and user of IE8.

demon added a comment.Feb 24 2011, 1:25 PM

It's also confirmed in IE6, but also seems limited to XP.

Definitely not a problem in Win7.

(In reply to comment #14)

It's also confirmed in IE6, but also seems limited to XP.
Definitely not a problem in Win7.

Changed the summary of this bug. IE6 is very old and seems we are not going to support it anymore...

Reedy added a comment.Feb 24 2011, 1:27 PM

We support IE6, just.

Can you get them to try it again now, as we've just made a site config change.

Thanks

(In reply to comment #16)

We support IE6, just.
Can you get them to try it again now, as we've just made a site config change.
Thanks

Still not OK using IE8 and Win XP.

ayg wrote:

The site briefly appears, then disappears, then this error message appears:

We were unable to return you to wikipedia.org. 
 
 Internet Explorer has stopped trying to restore this website. It appears that the website continues to have a problem. 
 What you can do: 
   Go to your home page 
 
   Try to return to wikipedia.org 
 
   More information

When a website causes a failure or crash, Internet Explorer attempts to restore the site. It stops after two tries to avoid an endless loop.

ja.wikipedia.org loads fine, so does zh.wiktionary.org and zh.wikisource.org. If I disable script (in IE8, F12 -> Disable -> Script), it doesn't crash. So the problem is likely some sort of bad interaction between an existing site script and some 1.17 JS changes like ResourceLoader, which combine to trigger a crash bug in IE on XP.

I'd suggest that zhwiki sysops disable chunks of site JavaScript until the problem goes away. To avoid disruption, you can disable the scripts by wrapping them in a User-Agent check that looks for IE on XP, instead of commenting them out entirely.

PhiLiP.NPC wrote:

I have just reverted r15816978 which was made to [[:zh:MediaWiki:Common.js]]. Please purge your IE cache (or use Ctrl + F5) then test again.