Page MenuHomePhabricator

Set default for $wgVectorUseSimpleSearch to true
Closed, ResolvedPublic

Description

By current default, the Vector skin does not use the simplified search box. To take advantage of the simplesearch feature one must add this to your LocalSettings.php file:

$wgVectorUseSimpleSearch = true;

In this bug I suggest to change the default for new installation and users to $wgVectorUseSimpleSearch = true;

  1. I am interested to know the reason why the default was/is set to 'false'?
  2. Do you agree if I change the default to 'true' ?

Version: 1.17.x
Severity: enhancement

Details

Reference
bz29374

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:32 PM
bzimport set Reference to bz29374.
Wikinaut created this task.Jun 13 2011, 3:41 PM

CC-ing myself

brion added a comment.Jun 13 2011, 4:52 PM

Adding bug 23985 as dependency -- is this still going on?

Is bug 23985 really a blocker for this? It doesn't cause any functional issues as far as I know, many wikis are happily using simple search.

(In reply to comment #3)

Is bug 23985 really a blocker for this? It doesn't cause any functional issues
as far as I know, many wikis are happily using simple search.

Yeah, including Wikimedia.

  • Enabled by default in core: I418cd542
  • Removed comment in Vector/README: Id57a36c3

Also note that the clash with mediawiki.legacy.mwsuggest, aside from being fixed long ago, becomes no longer relevant with its pending removal (bug 40448).

(moving to core as the feature's state is determined by core, the Vector extension merely enhances it)