Page MenuHomePhabricator

Upgrade to ICU 4.8 for WMF
Closed, ResolvedPublic

Description

I have no idea what is to be done here, but Tim mentioned that on bug 45596 comment 14, and if it's actually necessary, it has to be documented somewhere so I don't have to explain to every wiki separately why they can't have their collations yet.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=40462

Details

Reference
bz46036

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
OpenNone
Resolvedmatmarex
OpenNone
ResolvedNone
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedtstarling
ResolvedNone

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:40 AM
bzimport set Reference to bz46036.
matmarex created this task.Mar 12 2013, 6:24 PM

When you change the ICU version, you have to rebuild all the sort keys for wikis that use uca-* collations, with updateCollation.php --force. Lucid has ICU 4.2, and precise has 4.8, so when the upgrade to precise was in progress, Faidon built a custom php5-intl compiled against ICU 4.2.

The upgrade to precise is now complete, so the next task is to remove the custom php5-intl package and run updateCollation.php --force on the uca-* wikis. The fewer wikis that have to be treated this way, the easier it will be. And migrating wikis to uca-* at this stage is wasted effort, since the results of running updateCollation.php on ICU 4.2 will need to be thrown away within a day or two.

Just a note that I asked Reedy and this is happening right now, and will be done in a few days tops.

Reedy added a comment.Mar 16 2013, 1:05 AM

Per your IRC ping, all the processes Tim was running have now been completed

Reedy added a comment.Mar 16 2013, 1:15 AM

reedy@fenari:~$ mwscript eval.php enwiki

echo INTL_ICU_VERSION;

4.8.1.1

reedy@fenari:~$ ssh mw1082
Welcome to Ubuntu 12.04 LTS (GNU/Linux 3.2.0-29-generic x86_64)
The last Puppet run was at Tue Jan 22 19:13:59 UTC 2013 (29 minutes ago).
Ubuntu 12.04 LTS auto-installed on Thu Sep 20 20:19:21 UTC 2012.

Last login: Fri Mar 15 01:54:50 2013 from fenari.wikimedia.org
reedy@mw1082:~$ php /^C
reedy@mw1082:~$ dpkg -l | grep icu
ii libicu42 4.2.1-3ubuntu0.10.04.1 International Components for Unicode
ii libicu48 4.8.1.1-3 International Components for Unicode
ii ploticus 2.41-3.1 script driven business graphics package
ii ploticus-doc 2.41-2 Documentation and gallery of examples for ploticus
reedy@mw1082:~$ sudo -u apache php /usr/local/apache/common/multiversion/MWScript.php eval.php enwiki

echo INTL_ICU_VERSION;

4.8.1.1

Tim, can this be closed now, then?

And can we proceed with further UCA collations deployments? :) (particularly those makred as depending on this change)

Yes, those deployments can continue.

mxn added a subscriber: mxn.Nov 24 2014, 9:01 PM