Page MenuHomePhabricator

CSS resize horizontal in the unit translation dialog is useless because this makes the textarea overflow the hints and triggers a FF bug; vertical isn't and doesn't
Closed, ResolvedPublic

Description

resizer showing up wrongly orientated

Original title:
The resizer image in the unit translation dialog must be mirrored when translating to RTL languages

And, if your user language is a LTR language, the box is expanded towards the wrong direction (not where the resize graphic is shown).

Attached:

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:31 AM
bzimport set Reference to bz48817.
Rillke created this task.May 25 2013, 7:02 PM

That is feature of your browser. Please provide your browser name, version, language of your interface and language you are translating to.

As always (and I included this many times, even in my bugzilla user name but someone removed it):
Unless otherwise noted, I am using:

  • The latest Firefox release (21.0)
  • Language in the prefs: de
  • Language translating to: fa (which is visible in the screenshot)

I did some testing and found that if the CSS resize-property is set to *vertical* it shows correctly. And I am nearly sure that you wanted to set it to *vertical* and not to *horizontal* because this is quite useless.

Here is the translate link:
https://commons.wikimedia.org/w/index.php?title=Special:Translate&group=page-Template%3AWatchlistNotice%2FTranslation&filter=&action=translate&language=fa

Note that I can not resize the text boxes vertically (only horizontally) when selecting "outdated" translations. This is highly annoying.

Created attachment 12986
useless horizontal resize

this is related to https://github.com/wikimedia/mediawiki-extensions-Translate/blob/master/resources/js/jquery.autosize.js

Attached:

Created attachment 12987
even worse: You can not resize vertically and autosize does not work!

In the outdated-view, you autosize does not work and you cannot resize the text box in a useful manner.

Attached:

Change 76298 had a related patch set uploaded by Rillke:
Make jquery.autosize aware of style changes

https://gerrit.wikimedia.org/r/76298

Change 76482 had a related patch set uploaded by Rillke:
Make jquery.autosize aware of style changes

https://gerrit.wikimedia.org/r/76482

I've tested this patch on translatewiki.net production with Firefox 22.0 on OSX 10.8.4 with URL at https://translatewiki.net/wiki/Special:Translate/ext-universallanguageselector?filter=&action=translate&uselang=he&debug=true. In Chrome I (still) see expected behavior, and it looks to me like I see little change in Firefox.

  1. The resize icon still appears in the same place and with the same orientation as in attachment 12396. If that is what gerrit 76482 aimed to resolve, it doesn't do that, right?
  1. Attachment 12986 mentioned "useless horizontal resize". I'm note sure what that means (horizontal resize should not be possible?). I still see the behavior mentioned in that attachment. Is that what is expected?
  1. Attachment 12987 appears to express a feature request ("Make it possible to increase height of translation editor arbitrarily" - instead of based on the number of lines in the editor, with a maximum). Is that correct? If so, I'd like to propose we keep that out of scope of this issue, and a new issue is reported for that.

Change 76298 abandoned by Rillke:
Make jquery.autosize aware of style changes

Reason:
Follow on rETRA6b08237d431f

https://gerrit.wikimedia.org/r/76298

(In reply to comment #8)

  1. ... If that is what Gerrit change #76482 aimed to resolve

No, this not yet. I will report this upstream.

  1. horizontal resize should not be possible

Yes, perhaps, or better we do not interfere with the defaults at all. Users should be free to choose and customize their browsers according to their wishes.

  1. appears to express a feature request

No. It is a bug. Somewhere in the code, one texarea is initially created and .autosize() is called on it. If that textarea is then shown it is too small:
"In the screenshot provided as attachment #3 in bug 48817, the font size
is 16px in the visible textarea and 13px in the mirror due to this
issue."
To reproduce, you need a page that has only one outdated translation and FF 22.

  1. Will be solved by the patch. Everything else would need discussion.

Perhaps issue 3 should be a separate bug. But since it was all about resizing and being unable to, I've put it in here.

Change 76482 merged by jenkins-bot:
Update jquery.autosize

https://gerrit.wikimedia.org/r/76482

Patch for 3) got merged, hence resetting status as per comment 11

@Rillke The autosize library was updated recently. Could you check which issues are still present?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2016, 7:29 AM

It sais "Nothing to translate" everywhere at Commons.

Selecting another group throws
TypeError: content is undefined
https://commons.wikimedia.org/w/load.php?debug=false&lang=en ...
Line 191

Probably a new bug? Need details?

So I went to a translatable page directly and recorded

It would be nice if I'd be still in control of a text area size, and there won't be this confusing resize-handle. But really, there are more important matters.

Nikerabbit added a comment.EditedMar 23 2016, 3:58 PM

Oh I am not actually sure the updates are in Commons yet. Do you have translatewiki.net account to try there?

I am also trying to look what is wrong with Commons.

Change 279136 had a related patch set uploaded (by Nikerabbit):
Disable user resize of translation textareas

https://gerrit.wikimedia.org/r/279136

Change 279136 merged by jenkins-bot:
Disable user resize of translation textareas

https://gerrit.wikimedia.org/r/279136

Nikerabbit closed this task as Resolved.Apr 18 2016, 6:58 AM
Nikerabbit removed a project: Patch-For-Review.
Nikerabbit updated the task description. (Show Details)