Page MenuHomePhabricator

[Regression] wikitech.wikimedia.org is sending empty Echo notification emails
Closed, DeclinedPublic

Description

In bug 53771 Roan noted receiving an empty e-mail from wikitech:

To: Catrope <roan@wikimedia.org>
Subject: New notification at Wikitech
X-PHP-Originating-Script: 0:UserMailer.php
From: MediaWiki Mail <noc@wikimedia.org>
Reply-To: No Reply <noc@wikimedia.org>
Date: Wed, 04 Sep 2013 19:03:04 +0000
Message-ID: <labswiki.522783e832fdd3.58527144@wikitech.wikimedia.org>
X-Mailer: MediaWiki mailer
MIME-Version: 1.0
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: 8bit

You have a new notification.


To control which emails we send you, check your preferences:
https://wikitech.wikimedia.org/wiki/Special:Preferences#mw-prefsection-echo


Benny Situ commented that this is the "default notification message for email if a notification type doesn't define such message."
I got the same empty e-mail, and my notifications from Wikitech are all special ones from the OpenStack integration code, such as:

Hashar built instance 'deployment-sql03' in project Nova

Resource:Deployment-prep

so it sounds like this code needs to define some messages.


Version: unspecified
Severity: normal

Details

Reference
bz53778

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:51 AM
bzimport set Reference to bz53778.
bzimport added a subscriber: Unknown Object (MLST).

According to what I heard earlier (forgot who said it) this just needs Ryan (or someone else with access to wikitech wiki) to the proper update scripts.

Either way, please figure this out between Ryan and Echo. Whatever the case is, this looks broken and needs to be fixed.

This is fairly annoying. It should at least contain the message you see when you sign in to Wikitech.

scfc added a comment.May 4 2014, 9:55 PM

With Ryan being elsewhere, unassigning for the moment.

It looks to me like OpenStackManager needs to implement the onBeforeCreateEchoEvent hook [0] to provide the proper messages for the email subject and body. The implementation in Thanks [1] could probably be used as a reference. Additional instructions can be found in the Echo Developer guide [2].

[0]: https://www.mediawiki.org/wiki/Extension:Echo/BeforeCreateEchoEvent
[1]: https://github.com/wikimedia/mediawiki-extensions-Thanks/blob/master/Thanks.hooks.php#L128-L172
[2]: https://www.mediawiki.org/wiki/Echo_(Notifications)/Developer_guide#Hook_the_notification_into_the_Echo_extension

Change 144334 had a related patch set uploaded by BryanDavis:
Add Echo email customization

https://gerrit.wikimedia.org/r/144334

Change 144334 merged by jenkins-bot:
Add Echo email customization

https://gerrit.wikimedia.org/r/144334

[2014-07-24T03:36:49] <bd808> andrewbogott_afk: I haven't gotten any echo notification emails from wikitech since Sun, 20 Jul 2014 21:38:05 +0000. I'm more than a bit worried that my patch to change the echo emails broke something.
[2014-07-24T03:41:17] <bd808> andrewbogott_afk: < legoktm> umm, is wikitech running processEchoEmailBatch.php?
[2014-07-24T03:41:34] <bd808> andrewbogott_afk: < legoktm> by adding "email-body-batch-params" and "email-body-batch-message" I think you enabled batching support, which requires a script to be run
[2014-07-24T03:41:45] <legoktm> okay, I'll just talk in here now :P
[2014-07-24T03:42:55] <bd808> legoktm: I was just queuing up things for Andrew's bouncer to tell him in the morning :)
[2014-07-24T03:44:45] <legoktm> bd808: is wikitech's configuration public anywhere?
[2014-07-24T03:44:54] <legoktm> $wgEchoEnableEmailBatch = false; should fix it
[2014-07-24T03:45:12] <legoktm> but people would miss emails...setting up a cronjob is probably better
[2014-07-24T03:45:20] <bd808> I don't think the config is public. At least I've never seen it.
[2014-07-24T03:45:29] <Krinkle> Indeed, not public and not versioned.
[2014-07-24T03:45:38] <bd808> poor wikitech
[2014-07-24T03:45:50] <bd808> the cobbler's children...
[2014-07-24T03:46:26] <legoktm> :(

So you fixed the bug by not sending out any emails at all? Haha, nice

What's the next step now?

Well, there was Gerrit change 149459

(In reply to Alex Monk from comment #10)

Well, there was Gerrit change #149459

Andrew ran the batch send manually yesterday and it did send out some emails, but apparently only for people who had selected batch notification in their preferences. The gerrit change referenced should continue to send batches, assuming of course that Echo is placing message requests in the database table.

Last I heard we still didn't know why emails were not being sent for users like me who have individual delivery specified in their preferences.

Krinkle removed a subscriber: Krinkle.May 10 2016, 9:12 PM
bd808 closed this task as Declined.Jun 8 2017, 4:43 AM

This has either been fixed or everyone has gotten used to it being this way. I think it's actually the former.