VisualEditor: opening square brackets can sometimes disappear
Closed, DeclinedPublic

Description

Trying to type a word in brackets might lead to the disappearing of the opening brackets, no wikitext warning appears and no nowikis are added.

Happened to me twice in sandboxes,
see https://test.wikipedia.org/w/index.php?title=User:Elitre_(WMF)/tests&oldid=185158 and https://it.wikipedia.org/w/index.php?title=Utente%3AElitre_%28WMF%29%2FSandbox_VE&diff=62542564&oldid=62363821 ;
it didn't happen in https://en.wikipedia.org/w/index.php?title=User%3AElitre_%28WMF%29%2FSandbox&diff=582254513&oldid=581339890 and I also don't seem able to get this bug while VEditing ns0.
All tests under Chrome and Vector.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=53856

Details

Reference
bz57207
bzimport set Reference to bz57207.
Elitre created this task.Nov 18 2013, 8:13 PM

I've been unable to replicate this in Mac OS 10.7.5/Safari 6/Vector or in Mac OS 10.7.5/Firefox 25.0.1/Vector, in either userspace or the mainspace.

Yeah, it's probably Chrome.

I can't reproduce this after a few dozen tries. Can you give more details about how it happens? Is it on new pages only? Existing pages? Existing pages when you're editing an old revision? At the start of the document? Everywhere? Etc.

I guess we'll never know, since right now it seems to work again just fine. Good for us.

Sorry :/
Chrome, Vector, Win7:

https://en.wikipedia.org/wiki/User:Elitre_(WMF)/sandbox?veaction=edit
Cursor right under the sandbox template and above the article text,
I start typing brackets and they disappear.

It doesn't happen in FF, but it's still there if I switch to Monobook in Chrome.

I still can. VE hates me :(

Is this still occurring?

Closing provisionally as WORKSFORME.

Happening again.
In https://fr.wikipedia.org/w/index.php?title=Utilisateur:Elitre_(WMF)/Prove2&oldid=108482122 I tried to start a new line precisely under the first one (the one ending in "sdas") with a word in brackets to see if it triggered the warning.
After typing the opening square brackets, these disappear when I start typing a word.

Also happening at https://test.wikipedia.org/w/index.php?title=User:Elitre_(WMF)/Sandbox&oldid=203117 when trying to add a new point under "simpler".

Add Comment