VisualEditor: IMPLEMENT copy and paste from other VE instances (surfaces)
Closed, InvalidPublic

Description

Bug 41193 VisualEditor: Support copy and paste from other VE instances (surfaces) is now closed as FIXED yet a fully working cut and paste is not.
Some of the bits of copy and paste still not working are documented at http://en.wikipedia.org/w/index.php?title=Wikipedia:VisualEditor/Feedback&curid=37904286&diff=585650020&oldid=585645740

#External links? {{Tick}} This seems usually to work (not completely the same, but near enough). Mind you, external links in templates go completely haywire though...
#Internal links? {{Cross}} I took one line from [https://www.mediawiki.org/wiki/Manual:FAQ?veaction=edit FAQ], "where do I donwload MediaWiki?". One single line, that's all. [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840546] Most other examples below contain further cases of internal links gone wrong
#References? {{Cross}} I tried to copy [https://www.mediawiki.org/wiki/Manual:Backing_up_a_wiki?veaction=edit] (the whole page), to get a page with a reference (not common on Mediawiki). The result is baffling but amusing[https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840568]. If you go to the reference at the bottom of that page, and click the "arrow" at the left (taking you up to the place in the same page where that reference is used, no?) then suddenly you end at the original page, in VE edit mode!
#List bullets? {{Cross}} [https://www.mediawiki.org/wiki/Files_and_licenses_concept?veaction=edit], section Display, gives [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840576] Note how multiple lines from the original are squashed together in the copy
#Images? {{Cross}} I found an image in [https://www.mediawiki.org/wiki/Wikimedia_Foundation_Design?veaction=edit], section Code, Status: but the result [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840580] has no image, as part of the syntax is lacking...
#Templates? {{Cross}} I tried copying the template from [https://www.mediawiki.org/wiki/Communication?veaction=edit here, on the right]: the result is [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840544]. Something simpler? <nowiki>{{Note}}</nowiki> changes into <nowiki><span class=""><span class=""></span></span><span class=""> </span>'''Note'''<span class="">:</span></nowiki> [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840555]
#Tables? {{Cross}} Taken from [https://www.mediawiki.org/wiki/Manual:Code?veaction=edit], but the result is not quite the same [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840555], not the contents (yuk) nor the layout.
#Code? {{Cross}} I tried to copy the code from [https://www.mediawiki.org/wiki/Manual:FAQ?veaction=edit FAQ], section "How do I add extra namespaces?", but the result [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840549] is not quite the same as the original, and looking at the actual code underneath makes this even more obvious
#Further bugs? {{Cross}}, e.g. the sudden appearance of (actually quite nice) clouds as section headers[https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840559]
#Further bugs part 2? {{Cross}} But extremely funny! No idea what happened here, but I tried to copy a section from [https://www.mediawiki.org/wiki/Download?veaction=edit], section "Development releases", and nothing more. The amazing result, starting from an empty page, is [https://www.mediawiki.org/w/index.php?title=User%3AFram%2FSandbox&diff=840564&oldid=840563]. Don't ask me where that template at the bottom left comes from, I didn't ask for it!
#Further bugs part 3? {{Cross}}, again funny, perhaps the same as the one above: From [https://www.mediawiki.org/wiki/Wikimedia_Foundation_Design?veaction=edit] I copy the short sentence <nowiki>see the {{git file|project=mediawiki/core|file=resources/mediawiki.ui/sourcefiles|sourcefiles}} subdirectory.</nowiki> (shown here in wikitext format, but everything here is copied using VE only!), which looks originally like "see the resources/mediawiki.ui/sourcefiles subdirectory". The end result of this one sentence? [https://www.mediawiki.org/w/index.php?title=User:Fram/Sandbox&oldid=840587] Don't you love it?
#Further bugs part 4? {{Cross}} If I want to copy [https://www.mediawiki.org/wiki/Flow_Portal/Design/FAQ?veaction=edit Flow Portal/Design/FAQ], I can't. I can't paste it into my sandbox, and if I paste it in multiple parts, I can't save it (the save button doesn't work).


Version: unspecified
Severity: normal

bzimport added a project: VisualEditor.Via ConduitNov 22 2014, 2:13 AM
bzimport set Reference to bz58354.
SalixAlba created this task.Via LegacyDec 11 2013, 10:33 PM
Jdforrester-WMF added a comment.Via ConduitDec 11 2013, 10:35 PM

Please re-submit this as individual bugs, as you have been asked before. As it is, it's unactionable.

Aklapper added a comment.Via ConduitDec 12 2013, 9:15 AM

Sorry, but this bug report is not handable so I am closing it as INVALID (which does not refer to the bugs you mention, but to this report itself).
Please see https://www.mediawiki.org/wiki/How_to_report_a_bug

Aklapper added a comment.Via ConduitDec 12 2013, 11:56 AM

SO to recap: Filing issues is definitely welcome (though only one problem per report), and if I have enough time later today I might try to split this into separate reports. It's not that bug reports aren't welcome, it's that they need to be one issue per report (which is more work for reporters, I know :-/ ).

SalixAlba added a comment.Via ConduitDec 12 2013, 12:22 PM

Derk-Jan Hartman has responded on wiki http://en.wikipedia.org/w/index.php?title=Wikipedia:VisualEditor/Feedback&diff=585724128&oldid=585724057
so it looks like some of the work of splitting has been done.

  1. I suspect this might be caused by JS errors being thrown because of a copy action on the originating surface. All following copy actions from the source surface (even small ones) might then become corrupted I suspect. bug 58379
  2. Probably the same problem as 2
  3. I was not able to reproduce this: [28]
  4. I was not able to reproduce this: [29]
  5. I was not fully able to reproduce this, but there seems to be in issue in the paragraph following the template. bug 58384
  6. This seems to be because this table also doesn't render properly in the original surface to begin with. bug 58387
  7. I was not able to reproduce this [30], but again, if 2. occurred in the original source surface before your action, then this might cause that I guess. Also it seems that the syntax highlight classes are not dynamically loaded when you paste this content into the target. I reported this as bug 58388
  8. Clouds seem to be the result of pasting something over existing content. bug 58389
  9. not able to reproduce this yet.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.