Page MenuHomePhabricator

VisualEditor: Selecting border in Media Settings>Advanced Settings does not add any value to the image type field
Closed, ResolvedPublic

Description

Steps to reproduce:

1.Open a page with VE
2.Insert an image
3.Go to Media Settings>Advanced Settings for that image
4.Select the option Border under Image Type

Observed Result:
There is no value/Change appears for this image type
The resulting wikitext is:
[[File:Wheat (flo).JPG|200x200px||left]]

Test Environment: http://en.wikipedia.beta.wmflabs.org/
Browser: Chrome Version 26.0.1410.65
OS: MAC OS X 10. 8. 5
Page:http://en.wikipedia.beta.wmflabs.org/w/index.php?title=10thFeb&action=edit


Version: unspecified
Severity: normal

Details

Reference
bz61155

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:57 AM
bzimport set Reference to bz61155.
Ryasmeen created this task.Feb 10 2014, 8:27 PM

Cannot replicate in master in both Chrome 32 and Firefox 27 under Ubuntu.

Found the bug, the wikitext doesn't have |border even though the CE is updated.

This commit seems to fix it: https://gerrit.wikimedia.org/r/#/c/112041/

Change 112041 had a related patch set uploaded by Jforrester:
Revamp media edit dialog's position widget

https://gerrit.wikimedia.org/r/112041

Change 112041 merged by jenkins-bot:
Revamp media edit dialog's position widget

https://gerrit.wikimedia.org/r/112041

Still not working for me.I could still reproduce it in page:http://en.wikipedia.beta.wmflabs.org/w/index.php?title=27thfebff&action=edit

See the screenshot attached

Created attachment 14708
Screenshot

Attached:

Change 115939 had a related patch set uploaded by Mooeypoo:
[wip] Deal with 'none'/'border' and default size in media edit

https://gerrit.wikimedia.org/r/115939

Change 115939 merged by jenkins-bot:
Deal with 'none'/'border' and default size in media edit

https://gerrit.wikimedia.org/r/115939

Verified the fix in Betalabs

Verified the fix in test2