Page MenuHomePhabricator

Upload hangs after "describe" step
Closed, ResolvedPublic

Details

Reference
bz64698

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:22 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz64698.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.May 1 2014, 7:52 AM
KTC added a comment.Aug 7 2014, 10:16 AM

Not only applicable when uploading PNGs. It happens to me all the time while uploading JPEGs. Size of the images may contribute to the problem though.

Katie, do the files also have big descriptions? Can you provide us with a log of any API requests that UW makes in these cases? Or an example image that causes the problem?

Gilles triaged this task as Normal priority.Nov 24 2014, 2:28 PM
Gilles added a subscriber: Gilles.
KTC added a subscriber: KTC.Dec 13 2014, 9:17 PM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:36 PM
Restricted Application added subscribers: Steinsplitter, Matanya, Aklapper. · View Herald TranscriptSep 4 2015, 6:36 PM
MarkTraceur lowered the priority of this task from Normal to Low.Dec 3 2015, 4:44 PM

Old bug, probably not an issue anymore. If @KTC comes back, and can give us an example image that still causes this bug, that would be super.

Well, some reports I got from WLM users may match this bug (like a dozen others).

Do you have any details from those reports? Console output, example images, example descriptions, categories, locations, file types, preferences set, browsers, browser versions, etc.?

No. :( I asked my sources to be more precise next time.

KTC added a comment.Dec 3 2015, 9:49 PM

It having been ignored for more than a year doesn't mean it's "probably not an issue anymore", especially if no unrelated changes have been made that might have fixed it indirectly. I have no recent experience of the problem because I have been using an external uploader (VicuñaUploader) for quite a while to specifically avoid the issues. Don't think "don't use our own uploader, use something else" is how we want to solve issues with the UploadWizard.

I just spent a lot more time than it would be reasonable playing with an old-ish version of UploadWizard, e43d3d16e98488ba67a7731f3a1a18bcc10d9eaa (2014-05-22), which seems to be the oldest one that works with current MediaWiki. I couldn't reproduce this problem, just like I can't reproduce it with modern UploadWizard.

I don't think it would be a good use of our time (and donor money ;) ) to continue chasing this phantom. We have fixed a number of important issues relating to uploading in recent months (including T48741, T71691, T94562, T106968, T101616, T92801), but none of them looks related to this one. I trust that you understand that it's hard to tell which of the other ~800 changes to UploadWizard since when you filed this bug could have affected this. Especially since we don't actually know what the cause was.

If a different uploader satisfies your needs better than UploadWizard, then by all means do use it, I don't see why not. UW tries to cater to beginner users more than advanced ones in some places, perhaps unlike Vicuña.

According to https://commons.wikimedia.org/wiki/Special:ListFiles/Tim_Adams, the original reporter "fixed" the issue by stopping uploading PNG files: he only uploads in JPG format now. It seems the failure was very consistent for him, I'll ask him to try again.

matmarex closed this task as Resolved.Nov 3 2016, 9:20 PM

With no further reports or details, and with all the work we did on issues similar to this (per my previous comment), I am confident this is resolved.