Page MenuHomePhabricator

Translate: Round percentages down (for message matching)
Closed, ResolvedPublic

Description

The matching percentage shown in the "Special:Translate" interface rounds to an integer value. There is however a huge difference between messages being 100% matches or 99.5% matches (an example is given below).

For this reason it would be better if the percentage is instead always rounded down to the nearest whole percent.

An example:
https://translatewiki.net/w/i.php?title=MediaWiki:Mwe-upwiz-source-ownwork-assert-cc-by-sa-4.0/sv&action=edit&uselang=en


Version: unspecified
Severity: minor

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:26 AM
bzimport set Reference to bz67671.
bzimport added a subscriber: Unknown Object (MLST).

Unable to reproduce. The 100% match seems to be identical to the current translation. Please reopen with more info if the issue is still present.

(In reply to Niklas Laxström from comment #1)

Unable to reproduce. The 100% match seems to be identical to the current
translation. Please reopen with more info if the issue is still present.

The link goes to the interface for individual messages where you can see the percentage to two decimal places.

The problem appears in the Special:Translate interface. To see the same message there follow the steps below:

  1. go to https://translatewiki.net/w/i.php?title=Special:Translate&group=ext-uploadwizard&language=sv&filter=&action=translate
  2. filter on "Creative Commons Erkännande-DelaLika 4.0".
  3. Pick the top option
  4. Notice the suggested 100% match which actually refers to the 3.0 license. This is the 99.60% match pointed out in the first comment.
Beta16 added a subscriber: Beta16.Dec 5 2014, 10:23 AM

Change 195224 had a related patch set uploaded (by Pmlineditor):
Round down message match percentage in Special:Translate

https://gerrit.wikimedia.org/r/195224

Nikerabbit closed this task as Resolved.Mar 12 2015, 7:28 AM
Nikerabbit claimed this task.

Change 195224 merged by jenkins-bot:
Round down message match percentage in Special:Translate

https://gerrit.wikimedia.org/r/195224