Page MenuHomePhabricator

Story: AnalyticsEng has editor_day table in labsdb
Closed, DeclinedPublic

Description

We need to create a permanent and vetted version the "editor_day" table from the analytics-store box in labsdb. Then, change Rolling Active Editor to use that table instead of the raw database. Without it, 'Rolling Active Editor' will never finish on time.


Version: unspecified
Severity: normal
Whiteboard: u=AnalyticsEng c=Wikimetrics p= 34 s=2014-11-13

Details

Reference
bz69145

Event Timeline

bzimport raised the priority of this task from to Unbreak Now!.Nov 22 2014, 3:37 AM
bzimport set Reference to bz69145.
bzimport added a subscriber: Unknown Object (MLST).
Nuria created this task.Aug 5 2014, 1:53 PM
  • Bug 69254 has been marked as a duplicate of this bug. ***
kevinator lowered the priority of this task from Unbreak Now! to High.Nov 26 2014, 12:50 AM
kevinator moved this task from Incoming to Coding and Testing on the Analytics-Engineering board.
kevinator renamed this task from Story: AnalyticsEng has editor_day table in labsdb to Story: AnalyticsEng has editor_day table in labsdb [34pts].Nov 26 2014, 1:02 AM
ggellerman renamed this task from Story: AnalyticsEng has editor_day table in labsdb [34pts] to Story: AnalyticsEng has editor_day table in labsdb .Dec 1 2014, 9:25 PM

Was 38 points...removing points from subj line because:

  1. This ticket had been in progress for some time. Team came to consensus that it was too big and changed scope of this ticket to encompass:
  • create rough draft of schema and data loading queries (gerrit)
  • create warehouse on stat1003 and grant access to research user with preliminary schema
  • vet data loaded by Sean (user table and edit tables)
    • this includes work by sean (tunning, perf & index creation)
    • sanity checking by analytics devs
    • run sample queries for metrics `
  1. other tasks from this ticket are now covered by https://phabricator.wikimedia.org/T76382

see also
https://etherpad.wikimedia.org/p/analytics-tasking

kevinator lowered the priority of this task from High to Low.Feb 26 2015, 7:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 12 2016, 7:42 PM
mforns closed this task as Declined.Mar 26 2019, 2:33 PM
mforns added a subscriber: mforns.

Declining because Wikimetrics is being discontinued. See: T211835.