Page MenuHomePhabricator

Create a SpecialPage that allows to edit label, description and aliases together
Closed, ResolvedPublic

Description

And do NOT call it Special:SetFingerprint.


Version: unspecified
Severity: normal
Whiteboard: u=dev c=frontend p=0

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 3:36 AM
bzimport set Reference to bz70174.
bzimport added a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).

@Lydia_Pintscher decided that a Special page titled "SetLabelDescriptionAliases" should be created:
Fingerprint <> EntityTerms <> LabelDescriptionAliases

Aude and I are suggesting to change the name to SetEntityTerms (which is pretty much a -1 for the patch). A generic name allows us to add more entity types to the special page later. This is not possible with the current name. We would need to implement a new special page every time somebody comes up with a different combination of terms (label, description, aliases and possibly other terms). @Lydia_Pintscher?

We had this discussion in the office already. The issue is that SetEntityTerms tells users exactly nothing. I think it is fine to go with a specialized one here that is more meaningful for our users.

Change 187423 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
Added Special page to set label, description and aliases at once

https://gerrit.wikimedia.org/r/187423

Patch-For-Review

Change 187423 merged by jenkins-bot:
Added Special page to set label, description and aliases at once

https://gerrit.wikimedia.org/r/187423

Tobi_WMDE_SW closed this task as Resolved.Feb 21 2015, 10:35 AM
Tobi_WMDE_SW claimed this task.
Tobi_WMDE_SW set Security to None.
Tobi_WMDE_SW moved this task from Backlog to Done on the § Wikidata-Sprint-2015-02-03 board.