Page MenuHomePhabricator

Can't easily add new section to user talk page
Closed, ResolvedPublic

Description

If I go to an article talk page, whether it exists or not, I'm offered a blue "Add discussion" button. If I go to a user talk page, I just get to see the talk page: clicking the "edit" icon gets me editing the top of the page, not a good idea, and the only way to add a new section is to edit the last section on the page - far from ideal.

Please provide an "Add discussion" button for user talk pages.


Version: unspecified
Severity: normal

Details

Reference
bz70614

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:46 AM
bzimport set Reference to bz70614.
PamD created this task.Sep 9 2014, 4:36 PM
PamD added a comment.Sep 9 2014, 4:38 PM

Sorry, should have included "In Mobile Beta on Android phone" in subject line and/or text.

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/5QU04zgo

(In reply to pamdavies7 from comment #0)

If I go to an article talk page, whether it exists or not, I'm offered a
blue "Add discussion" button. If I go to a user talk page, I just get to see
the talk page: clicking the "edit" icon gets me editing the top of the page,
not a good idea, and the only way to add a new section is to edit the last
section on the page - far from ideal.

Please provide an "Add discussion" button for user talk pages.

The "add discussion" and talk page overlay is still very much a work in progress, which is why it's not on user talk pages yet (and is still in beta) :) But yes, the plan is to eventually provide one consistent experience across all talk pages, regardless of namespace.

  • Bug 69484 has been marked as a duplicate of this bug. ***

@fionareidc@gmail.com:

it only shows discussions it's deemed "active"

Maybe this leaves place for some misunderstandings: active menas all discussions on the talk page, there is no timelimit to show them in the interface or something else. If a topic is on the Talk page (and not in the archive or subpages), it will be visible in MF, too, iirc.

Plus, the discussion interface only allows you to view one section at a time.

Hm, but you can switch back to the overview and go to the next topic? Is this to complicated? How we can make it more useful for you and other power user? Thanks for all constructive input :)

It's just so annoying to go to the talk page, read it to find out if my issue's already been discussed, go back to the article, click the discussion interface button, and then click the "new discussion" button.

Totally agree!

Change 166079 had a related patch set uploaded by Jdlrobson:
WIP: Add add discussion button to talk pages

https://gerrit.wikimedia.org/r/166079

Jdlrobson moved this task from 2014-15 Q2 to 2014-15 Q3 on the Readers-Web-Backlog board.
Jdlrobson set Security to None.

WIP patch at https://gerrit.wikimedia.org/r/166079 someone should feel to pick it up.

@Florian feel free to grab this one..

Florian claimed this task.Dec 31 2014, 11:59 PM

I'll take a look on it :)

Change 182397 merged by jenkins-bot:
Add "add discussion" button to talk pages

https://gerrit.wikimedia.org/r/182397

Jdlrobson closed this task as Resolved.Jan 15 2015, 9:49 PM