Page MenuHomePhabricator

WikiGrok v. B should show more than 1 tag per line
Closed, ResolvedPublic

Description

wikigrok v. b on beta labs

On iPhone 5/iOS 8:

  1. The tags in WikiGrok version B are centered rather than fitting to the width of the screen (see mock: https://trello.com/c/wYLhzlDl/12-5-add-alma-mater-to-wikigrok-version-b)
  1. The "nationality" label is missing from the suggested nationality tag

Version: unspecified
Severity: normal

Attached:

Details

Reference
bz72631

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:57 AM
bzimport added a project: MobileFrontend-alpha.
bzimport set Reference to bz72631.
bzimport added a subscriber: Unknown Object (MLST).
Maryana created this task.Oct 28 2014, 5:20 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/g1K3cKhO

I guess we need to make the tags smaller so that more than one can fit on a line.

The nationality problem may have been caused by https://gerrit.wikimedia.org/r/#/c/168695/

Change 169570 had a related patch set uploaded by Kaldari:
Fix nationalities label in WikiGrok v B

https://gerrit.wikimedia.org/r/169570

Change 169570 merged by jenkins-bot:
Fix nationalities label in WikiGrok v B

https://gerrit.wikimedia.org/r/169570

I don't know how we can solve the tag problem. To be frank the design is just not that good... it hasn't considered the variable text length nor i18n. We can make it spill on to two lines but that completely breaks the design. These are the kind of problems I raised back in the beginning about why we should be using standard controls.

The nationality issue is fixed, so removing that from the bug title.

CCing Moiz for design input...

i18n shouldn't be an issue right now; we're on enwiki only at this stage :) And we don't have a standard design to solve this, since it's a completely novel workflow. That's the point of building it in alpha/beta first and testing.

kaldari closed this task as Resolved.Dec 5 2014, 7:29 PM
kaldari claimed this task.