Page MenuHomePhabricator

odd behavior with captcha when adding links as anon/unconfirmed user
Closed, ResolvedPublic

Description

on wikitext pages, I find the behaviour somewhat odd. The captcha doesn't get triggered until after i hit save (since it has to check if I am adding a link and am anon or unconfirmed). Then a captcha is displayed next to the save button along with a message "Your edit includes new external links. To protect the wiki against automated spam, we kindly ask you to enter the words that appear below in the box (more info):" while above the edit box at the top it tells me "Error
Incorrect or missing CAPTCHA." I didn't even get a chance to enter the captcha yet, so imho it shouldn't be warning me.

http://snag.gy/GIq7C.jpg

(also when I first saw "Incorrect or missing CAPTCHA", I thought it meant that the captchas were somehow not found on the server and didn't think it meant that the user didn't enter it yet)

and the message is "captcha-sendemail-fail" which just doesn't seem the right one to use here or is being abused / reused from something else? I don't see how this error has anything to do with email.

This appears to be caused by changes in the ConfirmEdit extension.

https://gerrit.wikimedia.org/r/#/c/136323/

Event Timeline

aude created this task.Jan 10 2015, 9:26 PM
aude raised the priority of this task from to Needs Triage.
aude updated the task description. (Show Details)
aude added a subscriber: aude.

This appears to be caused by changes in the ConfirmEdit extension.
https://gerrit.wikimedia.org/r/#/c/136323/

CC'ing the reviewers/authors of that patch.

Aklapper triaged this task as Normal priority.Jan 12 2015, 1:40 PM
Florian claimed this task.Jan 12 2015, 2:00 PM

This should be improved, yes :/ I revisit the code and work on it.

Change 184371 had a related patch set uploaded (by Florianschmidtwelzow):
Revert wrong erros message and CAPTCHA handling on EditPage

https://gerrit.wikimedia.org/r/184371

Patch-For-Review

Change 184371 merged by jenkins-bot:
Revert wrong error message and CAPTCHA handling on EditPage

https://gerrit.wikimedia.org/r/184371

Florian closed this task as Resolved.Jun 12 2015, 3:56 PM

Should be on wikipedias already, so fixed. Feel free to reopen this task, if this isn't resolved, and thanks for reporting this, @He7d3r :)