Page MenuHomePhabricator

Localised name for Educational Program in ruwiki
Closed, ResolvedPublic

Description

Please, change names of Educational Program namespaces in ruwiki to:
ns446 - Образовательная программа
ns447 - Обсуждение образовательной программы

Event Timeline

MaxBioHazard raised the priority of this task from to Needs Triage.
MaxBioHazard updated the task description. (Show Details)
MaxBioHazard added a subscriber: MaxBioHazard.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 1 2015, 6:52 PM
Aklapper triaged this task as Normal priority.Mar 2 2015, 7:56 AM
Rubin16 added a subscriber: Rubin16.Mar 8 2015, 9:25 AM
Glaisher added a subscriber: Glaisher.

Better to do this in the extension directly rather than having a Wikimedia specific one.

Glaisher claimed this task.Mar 8 2015, 4:33 PM

Change 195093 had a related patch set uploaded (by Glaisher):
Add Russian translations for namespaces

https://gerrit.wikimedia.org/r/195093

Might also want to have aliases for special pages. see here for full list.

'MyCourses' => array( 'Мои курсы' ),
'ManageCourses' => array( 'Управление курсами' ),
'Institutions' => array( 'Учебные заведения' ),
'Student' => array( 'Студент' ),
'Students' => array( 'Студенты' ),
'Courses' => array( 'Курсы' ),
'EducationProgram' => array( 'Образовательная программа' ),
'Enroll' => array( 'Зарегистрировать' ),
'Disenroll' => array( 'Исключить' ),
'StudentActivity' => array( 'Активность студента' ),
'Articles' => array( 'Статьи' ),
'CourseActivity' => array( 'Активность на курсе' ),
Meirae added a subscriber: Meirae.Mar 8 2015, 5:01 PM

Updated patch has the special page aliases as well.

Change 195093 merged by jenkins-bot:
Add Russian translations for namespaces and special page aliases

https://gerrit.wikimedia.org/r/195093

Glaisher closed this task as Resolved.Mar 23 2015, 4:01 PM
NickK reopened this task as Open.EditedApr 3 2015, 1:18 PM
NickK added a subscriber: NickK.

Is it possible to resolve T73953 ASAP?

The problem is that Russian is a default fallback language for Ukrainian Wikipedia (we wanted to remove in T39314 and in T39329 but it was rejected), so when there is no Ukrainian translation Russian translation is displayed.

Ukrainian community is very annoyed by the fact that Ukrainian Wikipedia now displays Russian name of the namespace, especially given that Russian request was submitted only in March 2015 (and it is already closed), while Ukrainian request was submitted in October 2014 and is still not resolved (see https://uk.wikipedia.org/wiki/Вікіпедія:Кнайпа_(технічні_питання)#Випадаюче_меню for the community discussion).

Thanks

Elitre added a subscriber: Elitre.Apr 3 2015, 1:32 PM
Glaisher closed this task as Resolved.Apr 3 2015, 3:14 PM

(no real reason to open this)

Glaisher set Security to None.
This comment was removed by Edgars2007.
MaxBioHazard reopened this task as Open.Apr 29 2015, 6:09 AM
Mjbmr moved this task from Backlog to Done on the Wikimedia-Site-requests board.May 4 2015, 2:26 PM