Page MenuHomePhabricator

Clarify short month names messages; remove genitive from Chechen dates
Closed, ResolvedPublic

Description

Please tell how to make these options default interface?

MediaWiki:January/ce
MediaWiki:February/ce
MediaWiki:March/ce
MediaWiki:April/ce
MediaWiki:May long/c
MediaWiki:June/ce
MediaWiki:July/ce
MediaWiki:August/ce
MediaWiki:September/ce
MediaWiki:October/ce
MediaWiki:November/ce
MediaWiki:December/ce


These are the long names of the months, but there are also messages for the short names: https://translatewiki.net/wiki/MediaWiki:Jan/ce vs. https://translatewiki.net/wiki/MediaWiki:January/ce . Where are the long names used and where the short? Can names always be made long?

https://translatewiki.net/wiki/Thread:Support/MediaWiki:Jan/ce_and_MediaWiki:January/ce

Event Timeline

Umar created this task.Apr 1 2015, 6:34 AM
Umar raised the priority of this task from to Needs Triage.
Umar updated the task description. (Show Details)
Umar added a subscriber: Umar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2015, 6:34 AM
Aklapper changed the task status from Open to Stalled.Apr 1 2015, 3:31 PM

Why was this support request ("How can I...?") brought up here? Is there a software bug or missing functionality?
If so, please provide a list of steps how to reproduce the problem.
Also see https://www.mediawiki.org/wiki/Template:I18n_month

Nemo_bis updated the task description. (Show Details)Apr 1 2015, 4:06 PM
Nemo_bis set Security to None.
Nemo_bis renamed this task from Date of the default interface to Clarify the purpose of short month names messages.Apr 1 2015, 4:11 PM
Nemo_bis changed the task status from Stalled to Open.
Nemo_bis updated the task description. (Show Details)

The short names are used almost everywhere, in all timestamps: for instance Special:Log, Special:Preferences, action=history, signatures (~~~~). I don't remember where the long names are used.

You can decide how to translate the short forms. If there is absolutely no grammatical abbreviation for names in your language (!), you can keep the long name. However, it's better if you manage to find a reasonably short size (usually 2–4 characters) which all month names can be abbreviated to.

Does this answer your question? If yes (and if people agree on my advice), we'll update the qqq.

Nemo_bis triaged this task as Normal priority.Apr 1 2015, 4:20 PM
Umar added a comment.Apr 1 2015, 4:23 PM

Now we have all shown that MediaWiki:January-gen/ce there I want to make a transfer so this case but it should not check everywhere as it is now. if it is done somewhere other places tell me where?

Umar added a comment.Apr 1 2015, 5:04 PM

sort of translation also need to Chechen Wikipedia

https://translatewiki.net/w/i.php?title=MediaWiki:January-gen/ce&oldid=6049956

but it should not appear anywhere

it should use this translation everywhere
MediaWiki:January/ce

Whether jan/january/january-gen is used in timestamps is defined in $dateFormats. Chechen language does not currently define those, so they are taken from the fallback, Russian: https://phabricator.wikimedia.org/diffusion/MW/browse/master/languages/messages/MessagesRu.php;215f0327fe5dc3f5e66c7acf92789e5f6be4f5d4$393

In the cryptic strings, xg means the X-gen messages if I remember correctly.

Umar added a comment.Apr 1 2015, 9:29 PM

I think I wrote this message correctly the point here is that https://ce.wikipedia.org/w/index.php?title=%D0%9A%D0%BE%D1%8C%D1%80%D1%82%D0%B0_%D0%B0%D0%B3%D3%80%D0%BE&action=history must show the name of the month from here MediaWiki:January/ce Now there appears these are MediaWiki:January-gen/ce. If you do not understand please tell me.
and that's what I'm asking is possible to do?

So you are saying that Chechen doesn't use genitive in dates?

Umar added a comment.EditedApr 3 2015, 11:43 AM

In most cases, genitive is not used for dates in Chechen (however, in some cases generative for months is necessary).

however, in some cases generative for months is necessary

Which cases?

That doesn't help me...

Umar added a comment.Apr 4 2015, 4:26 AM

Not knowing English hard for me to explain it. But I think if you make MediaWiki:January/ce main is to solve the problem.

Well, as I understood, Umar requested about changing system messages in Chechen version—from [Month-name]-gen to simple [Month-name], because [Month-name]-gen (Genitive case) used very rarely in the Chechen language. So, after that we can save right genetive form in all -gen messages: январехь, февралехь, мартехь, апрелехь, майехь, июнехь, июлехь, августехь, сентябрехь, октябрехь, ноябрехь, декабрехь. After that, {{CURRENTMONTHGEN}} will shown as апрелехь, but in other places April still be simple апрель, without genitive ending.

Umar added a comment.Apr 6 2015, 1:22 PM

Year must first be like this (2015, 18 март, 17:45)

Does the following look what you want? This is a screenshot from Special:Preferences with the proposed change.

Umar added a comment.Apr 7 2015, 12:19 PM

all correct.

Change 202388 had a related patch set uploaded (by Nikerabbit):
Set time and date formats for ce

https://gerrit.wikimedia.org/r/202388

Umar added a comment.Apr 7 2015, 2:20 PM

The first problem to be solved? Soul_Train explained about the problem.

Change 202388 merged by jenkins-bot:
Set time and date formats for ce

https://gerrit.wikimedia.org/r/202388

Nemo_bis renamed this task from Clarify the purpose of short month names messages to Clarify short month names messages; remove genitive from Chechen dates.Apr 9 2015, 7:29 PM
Nemo_bis closed this task as Resolved.
Nemo_bis assigned this task to Nikerabbit.
Nemo_bis added a project: MW-1.26-release.
Umar added a comment.May 13 2015, 9:57 PM

And you can do it by default? To see all the format.

Change 210888 had a related patch set uploaded (by Nikerabbit):
Set correct default date format for ce

https://gerrit.wikimedia.org/r/210888

Umar added a comment.May 14 2015, 12:48 PM

Thank you very much. And what will happen with the Genitive case?

Change 210888 merged by jenkins-bot:
Set correct default date format for ce

https://gerrit.wikimedia.org/r/210888