Page MenuHomePhabricator

One user often can't create new articles in VisualEditor while logged in
Closed, ResolvedPublic

Description

Mike has tested this on Chrome 41.0.2272.118 m, and IE 11.0.9600.17501 on Windows 7 with Vector.

We don't have a good reproducible case, but we think that the pattern might run something like this:

  • Click on a redlink (not from search results) to create a new page (automatically opens in the wikitext editor).
  • Decide that you want to create the page in VisualEditor rather than the (default) wikitext editor, so click the 'Create' tab to switch it.
  • Discover that the page is blank and everything's crashed.

We think that the problem isn't happening in "incognito" mode, but withiout a clear sequence of reproducible steps, it's a little difficult to be sure of that. He's done the usual steps of disabling gadgets in prefs, but not (yet) tried blanking common.js and vector.js files.

Event Timeline

Whatamidoing-WMF updated the task description. (Show Details)
Whatamidoing-WMF raised the priority of this task from to Needs Triage.
Whatamidoing-WMF added a project: VisualEditor.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 15 2015, 6:45 AM
Aklapper changed the task status from Open to Stalled.Apr 15 2015, 5:30 PM

How blank is the page? Entirely blank?
Could the affected user open the browser's console, add "?debug=1" to the URL (if the URL has no question marks; if it has already it is "&debug=1" instead), and take a look if there's something in the console?

Jdforrester-WMF triaged this task as Normal priority.Apr 17 2015, 4:47 PM
Jdforrester-WMF set Security to None.

@Whatamidoing-WMF: Could you answer the last comment?

@Whatamidoing-WMF: Does this still happen or should this be closed? How to contact Mike?

It can be closed; it doesn't seem to be happening any longer. Thanks.

Whatamidoing-WMF closed this task as Resolved.Sep 1 2015, 12:17 AM
Whatamidoing-WMF claimed this task.

I'm closing this because Mike says that it's no longer happening. If it re-appears, then we can re-open it.