Page MenuHomePhabricator

Add @scfc to #WMF-NDA
Closed, ResolvedPublic

Description

My "Trusted Access & Confidentiality Agreement", signed on 2013-06-25, should already be on file.

Event Timeline

scfc created this task.Apr 20 2015, 2:18 PM
scfc raised the priority of this task from to Needs Triage.
scfc updated the task description. (Show Details)
scfc added a project: WMF-NDA-Requests.
scfc added a subscriber: scfc.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 20 2015, 2:18 PM

@Dzahn @MBrar.WMF can you check Tim Landscheidt's NDA, please?

Was this done through an RT ticket?

We don't have an NDA on file for Tim Landscheidt and it doesn't look like he is an employee, so he wouldn't have signed one through HR. Would he be able to go through the new NDA process we finalized last week?

scfc added a subscriber: coren.Apr 20 2015, 7:47 PM

It was done (on my part) by sending the NDA via mail to @coren.

If "the new NDA process" is https://wikitech.wikimedia.org/wiki/Volunteer_NDA#Create_a_request, it would be blocked at "You will need to sign the NDA online. Please sign 'My Full Name - Country Of Origin'." because the link https://phabricator.wikimedia.org/legalpad/view/2/ gives "Access Denied: Restricted Legalpad Document" for me.

Said email was sent to and (presumably) filed by @LuisV_WMF at LCA; Tim being a volunteer rather than staff and the whole thing predating the current process.

Qgil added a comment.Apr 20 2015, 10:21 PM

Let's see if we can clarify this situation.

My "Trusted Access & Confidentiality Agreement", signed on 2013-06-25, should already be on file.

Did you receive a confirmation of the approval? A copy of the NDA signed by an Engineering manager like Erik, Rob, etc? Did you obtain special access or permissions thanks to this NDA? If you would have access to private tickets in Bugzilla or RT, you should have been added to WMF-NDA when we created the group.

Perhaps it is easier to start anew?

If "the new NDA process" is https://wikitech.wikimedia.org/wiki/Volunteer_NDA#Create_a_request, it would be blocked at "You will need to sign the NDA online. Please sign 'My Full Name - Country Of Origin'." because the link https://phabricator.wikimedia.org/legalpad/view/2/ gives "Access Denied: Restricted Legalpad Document" for me.

Yes, this is true by default for everybody. In order to start a new request we need

A list of permissions requested and the reasoning behind your request

(It looks like access to WMF-NDA is all what is required)

It is better to explain your use case and needs than it is to ask for specific permissions
Wikimedia Foundation employees supporting your request (CCed)

Perhaps it is easier to start anew?

Since Coren sent it to Luis, maybe we could find it in mail clients rather than asking him to go through the process twice.

What is scfc's full name so I can search my inbox?

What is scfc's full name so I can search my inbox?

Tim Landscheidt

I have them, and Daisy should have filed them for legal.

Luis, if you could forward to contacts@ I can ask Rachel to file them for legal.

Thanks!

Dzahn triaged this task as Normal priority.Apr 21 2015, 5:32 PM
Dzahn added a comment.Apr 21 2015, 5:36 PM

What's the technical part of this ticket? Is it just about phabricator permissions or also the LDAP group "nda"? The latter gives access to some monitoring tools like icinga and graphite.

scfc added a comment.Apr 21 2015, 7:31 PM

If it's for me to decide, Icinga and Graphite would be a plus (though fixing T62112 would be better :-)).

Dzahn added a comment.Apr 21 2015, 7:50 PM

I did the LDAP part because NDA has been confirmed to exist. Giving to Chase for the phabricator part.

Dzahn assigned this task to chasemp.Apr 21 2015, 7:50 PM
chasemp closed this task as Resolved.Apr 21 2015, 9:19 PM

This is a bit of a grey area since the process was changed to require C level approval...but since this isn't really going through the NDA process, but instead recognizing and verifying in a new system an existing agreement it makes sense to me to get it done.