Page MenuHomePhabricator

TransactionProfiler should not apply to using LCStoreDB
Closed, ResolvedPublic

Description

Seeing the following in the debug toolbar on action=view:

*Expectation (masterConns <= 0) by MediaWiki::main not met when using LCStoreDB*

[caches] LocalisationCache: using store LCStoreDB
[...]
Connected to database 0 at localhost
[DBPerformance] [GET] Expectation (masterConns <= 0) by MediaWiki::main not met:
 [connect to localhost (core)]
 TransactionProfiler.php line 298 calls wfBacktrace()
 TransactionProfiler.php line 146 calls TransactionProfiler->reportExpectationViolated()
 LoadBalancer.php line 550 calls TransactionProfiler->recordConnection()
 SqlBagOStuff.php line 160 calls LoadBalancer->getConnection()
 SqlBagOStuff.php line 245 calls SqlBagOStuff->getDB()
 SqlBagOStuff.php line 219 calls SqlBagOStuff->getMulti()
 MessageCache.php line 300 calls SqlBagOStuff->get()
 MessageCache.php line 881 calls MessageCache->load()
 MessageCache.php line 800 calls MessageCache->getMsgFromNamespace()
 MessageCache.php line 738 calls MessageCache->getMessageFromFallbackChain()
 Message.php line 1075 calls MessageCache->get()
 Message.php line 698 calls Message->fetchMessage()
 Message.php line 789 calls Message->toString()
 OutputPage.php line 928 calls Message->text()
 OutputPage.php line 976 calls OutputPage->setHTMLTitle()
 Article.php line 512 calls OutputPage->setPageTitle()
 ViewAction.php line 44 calls Article->view()
 MediaWiki.php line 395 calls ViewAction->show()
 MediaWiki.php line 273 calls MediaWiki->performAction()
 MediaWiki.php line 565 calls MediaWiki->performRequest()
 MediaWiki.php line 414 calls MediaWiki->main()
 index.php line 46 calls MediaWiki->run()
[...]
DatabaseBase::query: Writes done: DELETE FROM `objectcache` WHERE keyname = 'X'
[DBPerformance] [GET] Expectation (writes <= 0) by MediaWiki::main not met:
 query: DELETE FROM `objectcache` WHERE keyname = 'X'
 TransactionProfiler.php line 298 calls wfBacktrace()
 TransactionProfiler.php line 200 calls TransactionProfiler->reportExpectationViolated()
 Database.php line 1190 calls TransactionProfiler->recordQueryCompletion()
 Database.php line 3132 calls DatabaseBase->query()
 SqlBagOStuff.php line 282 calls DatabaseBase->delete()
 SqlBagOStuff.php line 219 calls SqlBagOStuff->getMulti()
 ParserCache.php line 143 calls SqlBagOStuff->get()
 ParserCache.php line 196 calls ParserCache->getKey()
 Article.php line 606 calls ParserCache->get()
 ViewAction.php line 44 calls Article->view()
 MediaWiki.php line 395 calls ViewAction->show()
 MediaWiki.php line 273 calls MediaWiki->performAction()
 MediaWiki.php line 565 calls MediaWiki->performRequest()
 MediaWiki.php line 414 calls MediaWiki->main()
 index.php line 46 calls MediaWiki->run()

Is there a way to avoid these log spam?

Similar to:

Event Timeline

Umherirrender raised the priority of this task from to Needs Triage.
Umherirrender updated the task description. (Show Details)
Umherirrender added a project: Wikimedia-Rdbms.
Umherirrender added a subscriber: Umherirrender.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 30 2015, 8:07 PM
Seb35 added a subscriber: Seb35.Jun 1 2017, 12:40 AM

Perhaps a duplicate of T154424.

Krinkle renamed this task from Expectation (masterConns <= 0) by MediaWiki::main not met when using LCStoreDB to Expectation (masterConns <= 0) by MediaWiki::main not met when using LCStoreDB.Jun 23 2017, 3:31 PM
Krinkle renamed this task from Expectation (masterConns <= 0) by MediaWiki::main not met when using LCStoreDB to TransationProfiler should not apply to using LCStoreDB.
Krinkle updated the task description. (Show Details)
Krinkle moved this task from Untriaged to Usage problem on the Wikimedia-Rdbms board.
Krinkle edited projects, added MediaWiki-Cache; removed MediaWiki-Internationalization.

Change 462130 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/core@master] Use a ScopedCallback to silence transaction profiler in SqlBagOStuff

https://gerrit.wikimedia.org/r/462130

Change 462130 merged by jenkins-bot:
[mediawiki/core@master] Use a ScopedCallback to silence transaction profiler in SqlBagOStuff

https://gerrit.wikimedia.org/r/462130

Umherirrender closed this task as Resolved.Oct 12 2018, 7:02 PM
Umherirrender claimed this task.
Umherirrender triaged this task as Medium priority.
Aklapper renamed this task from TransationProfiler should not apply to using LCStoreDB to TransactionProfiler should not apply to using LCStoreDB.Sep 1 2019, 12:27 PM