Page MenuHomePhabricator

"Browse topics" returns error "apiPreHandler returned false"
Closed, ResolvedPublic

Description

When you click "Browse topics" at the top of a page that doesn't have many topics, an error appears instead of the topic list.

This was caused by https://gerrit.wikimedia.org/r/#/c/206827/ , and specifically by flowBoardComponentTocFeatureMixinTopicListApiPreHandler (in flow-board-toc.js) returning false on line 84

Event Timeline

Catrope created this task.Apr 30 2015, 8:45 PM
Catrope assigned this task to matthiasmullie.
Catrope raised the priority of this task from to Unbreak Now!.
Catrope updated the task description. (Show Details)
Catrope added a subscriber: Catrope.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 30 2015, 8:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

A similar error appears when you try to change the sort order.

Fixing the prehandler thing at flow-component-event.js:907 exposes another issue when changing sort order. It complaints that another request is already in progress. Changing the sort order triggers a refresh of the TOC (flow-board-navigation.js:77).

Not sure but I think because of the refactor, the 'inprogress' classes are removed later than they used to be so a loadHandler cannot trigger a request because it looks like the original request is still in progress.

Change 208387 had a related patch set uploaded (by Matthias Mullie):
Only display API errors

https://gerrit.wikimedia.org/r/208387

Change 208387 merged by jenkins-bot:
Only display API errors

https://gerrit.wikimedia.org/r/208387

DannyH closed this task as Resolved.May 4 2015, 10:39 PM
DannyH added a subscriber: DannyH.