Page MenuHomePhabricator

ContactPage for stewards at Meta-Wiki
Closed, ResolvedPublic

Description

Hi,

We at the stewards team would like to have this extension configured on Meta such that users could contact us on our OTRS queue more easily. We've discussed this in our mailing list and we've got no objections. Recent events have made that we're contacted more often and would like to provide an easy way to contact us for all users.

Please note that, it appears that Special:Contact is already present in Meta. As you can see at here or here.

It would be awesome if we could have [[Special:Contact/stewards]] for us.

We have, however, doubts on the config side. As you can see in the extension page there are some variables that need to be provided. I'd appreciate guidance on what we should provide.

Thank you.

Event Timeline

MarcoAurelio raised the priority of this task from to Needs Triage.
MarcoAurelio updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2015, 6:04 PM
Krenair added a subscriber: Krenair.May 8 2015, 6:05 PM

It is installed on meta...

By the way, it'd be good if it could only be used by registered users and if $wgCaptchaTriggers['contactpage'] = true;

Thanks.

Krenair added a comment.EditedMay 8 2015, 6:07 PM

We could change this task so it's about creating a new form for you, but you'll need to come up with something like the mock in T95789 (try to keep it simpler than that!), and you'll also need to create a role account (not locked or any other thing preventing EmailUser) with the correct email address.

MarcoAurelio renamed this task from Install Extension:ContactPage on Meta-Wiki to ContactPage for stewards at Meta-Wiki.May 8 2015, 6:08 PM
MarcoAurelio updated the task description. (Show Details)
MarcoAurelio set Security to None.

We could change this task so it's about creating a new form for you, but you'll need to come up with something like the mock in T95789 (try to keep it simpler than that!), and you'll also need to create a role account (not locked or any other thing preventing EmailUser) with the correct email address.

Thank you for your help. I'm taking care of the role account. I've created User:Wikimedia Stewards at Meta.

Krenair updated the task description. (Show Details)May 8 2015, 6:36 PM
Xeno added a subscriber: Xeno.May 8 2015, 7:22 PM
Teles added a subscriber: Teles.May 9 2015, 3:02 AM
Teles added a comment.May 9 2015, 3:05 AM

It should be left clear on link display that people will be contacting stewards; not a general contact form.

It should be left clear on link display that people will be contacting stewards; not a general contact form.

"link display"? could you clarify?

Teles added a comment.May 9 2015, 10:34 PM

It should be left clear on link display that people will be contacting stewards; not a general contact form.

"link display"? could you clarify?

I mean, the text that is displayed on a link at Side Bar... but nevermind. I misunderstood and thought it would be used on Side Bar, but probably won't.

Would a simple form similar to Special:EmailUser be fine?

Would a simple form similar to Special:EmailUser be fine?

I had something in mind as the Dutch Wikipedia (https://nl.wikipedia.org/wiki/Speciaal:Contactpagina - with option to also send IP address etc), but apparantly it can't be used right now due to a rename of the account used for that contact form...

I had something in mind as the Dutch Wikipedia (https://nl.wikipedia.org/wiki/Speciaal:Contactpagina - with option to also send IP address etc),

This is doable.

but apparantly it can't be used right now due to a rename of the account used for that contact form...

There is this for fixing nlwiki's form https://gerrit.wikimedia.org/r/209967

Are we missing anything here? If not, want to work on the config for this @Glaisher ?

By the way, it'd be good if it could only be used by registered users [...]

Special:Email is better in that case? ContactPage allows both registered and unregistered users to use it and doesn't have an option for specifically disallowing unregistered users.

By the way, it'd be good if it could only be used by registered users [...]

Special:Email is better in that case? ContactPage allows both registered and unregistered users to use it and doesn't have an option for specifically disallowing unregistered users.

@MarcoAurelio: why do you only want registered users to email? I mean, the anonymous users should be able to reach out to us too... maybe even more so due to global blocks and they can already contact us via our regular email. Imho we should just use the ContactPage and make it available to everyone.

Hi,

@MarcoAurelio: why do you only want registered users to email? I mean, the
anonymous users should be able to reach out to us too... maybe even more so
due to global blocks and they can already contact us via our regular email.
Imho we should just use the ContactPage and make it available to everyone.

The point was to know who is writting to us complaining about global blocks
or requesting things. Specially when requesting global IPBE, we have to
answer back and tell them to provide their username. With Special:EmailUser
we know who is writting to us, while with Special:Contact as far as I know
one can erase the username field (maybe I am wrong). But I accede that if
this system also facilitates things to anonymous users, then I am OK with
it. Go for it. Thanks.

Do we need any extra additional fields or anything?

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJul 17 2015, 10:49 PM

Change 225509 had a related patch set uploaded (by Alex Monk):
Add basic contact form for stewards

https://gerrit.wikimedia.org/r/225509

And what do you guys want the page title and text (i.e. "Gebruik het onderstaande formulier om contact met ons op te nemen." from nlwiki) to say? Just the defaults?

I'm a bit lost here and would appreciate assistance. Please tell us what is exactly needed and we will try to provide.

I've tried to design a form as in T95789, but I very much lack time right now to do it well. However since the point is to help users contact us we need to know:

  • Username or IP address who is writting to us.
  • An email address.
  • A field to have users explain what's the reason for them to contact us.
  • A checkbox with something like a privacy warning about submitting data to OTRS, or to the privacy policy and ToU.

I think that the first two fields should be automatically filled and the users shouldn't be able to modify them. The fourth field and the checkbox should be mandatory to fill/check respectively. We don't want empty messages or people not warned. I thought also about adding a dropfield or further checkboxes for specific problems, but since we don't have subqueues, I think that'd be complicating things further.

As said, please advice. If anybody has further ideas, please do share as well.

Best regards.

Krenair added a subscriber: Slaporte.EditedJul 19 2015, 6:50 PM

So basically https://nl.wikipedia.org/w/index.php?title=Speciaal:Contactpagina&uselang=en-gb but with a mandatory checkbox about privacy/ToU (or something, I think we should ask WMF-Legal to figure out exactly what's needed here, CCing Stephen)... Does that seem right?

I don't think we can make FromName and FromAddress be fully required by the user's browser without changing ContactPage to array_merge AdditionalFields in rather than just adding it to the defaults.

Krenair removed a subscriber: Slaporte.
Krenair added a comment.EditedAug 12 2015, 2:52 AM

So basically https://nl.wikipedia.org/w/index.php?title=Speciaal:Contactpagina&uselang=en-gb but with a mandatory checkbox about privacy/ToU (or something, I think we should ask WMF-Legal to figure out exactly what's needed here, CCing Stephen)... Does that seem right?

That probably isn't going to work out for various complicated reasons - perhaps Trust-and-Safety can help figure out internally what WMF requires to go on this, if anything?

I don't think we can make FromName and FromAddress be fully required by the user's browser without changing ContactPage to array_merge AdditionalFields in rather than just adding it to the defaults.

This was wrong, you just set RequireDetails = true

For the record I'll look into this, likely next week. Our dept is short staff atm (Kalli and I at a child protection conference, Philippe out of the office etc) and so waiting until we come back is likely best.

Savh added a subscriber: Savh.Oct 27 2015, 10:21 AM

Is this waiting for someone to specify the configuration components to InitialiseSettings.php as in the bit for wmgContactPageConf?

No, this is waiting for WMF

Dereckson changed the task status from Open to Stalled.Nov 18 2015, 8:21 PM
Dereckson added a subscriber: Dereckson.

For the record I'll look into this, likely next week. Our dept is short staff atm (Kalli and I at a child protection conference, Philippe out of the office etc) and so waiting until we come back is likely best.

It's been a few months later and still nothing. @Jalexander, could you please look into this? :)

@Jalexander: Could you look into this? Or any idea who else could? Thanks in advance.

Restricted Application added a subscriber: JEumerus. · View Herald TranscriptMar 22 2016, 6:34 PM

@Jalexander: Could you look into this? Or any idea who else could? Thanks in advance.

Sorry it had been so long that I lost track of exactly what i was looking into here. It appears the issue is the terms of use/privacy policy requirements? I will have a lawyer look into it and/or confirm my thoughts. (I think we should be good with a link/disclaimer which we can do via a message but will confirm).

Basically the disclaimer is to inform the user that the data they submit will be sent, recorded and kept in the OTRS system. Users need to know where the information goes. I see above that we were asked for a design. Should it be on HTML or is there any example in the config I can look into?

Basically the disclaimer is to inform the user that the data they submit will be sent, recorded and kept in the OTRS system. Users need to know where the information goes. I see above that we were asked for a design. Should it be on HTML or is there any example in the config I can look into?

They've given me some suggested text (below) for us to use. They wanted to make sure we understood that it was only a suggestion and if you wanted to adapt it/adjust it that was totally fine as long as the general gist (especially about it going to the stewards/being ok with sharing with them) was covered.

WMF Legal suggested:

Disclaimer: All information you include in this form is submitted to, processed by, and responded to by volunteer community members (specifically Stewards), not the Wikimedia Foundation. Please do not include any information that you are not comfortable sharing with Wikimedia volunteers. Responses and other correspondence related to processing your submitted information are not to be considered official statements of the Wikimedia Foundation. For official correspondence, please contact the Wikimedia Foundation through the methods listed on https://wikimediafoundation.org/wiki/Contact_us.

Jalexander removed Jalexander as the assignee of this task.May 4 2016, 12:24 AM
Jalexander changed the task status from Stalled to Open.May 4 2016, 8:24 PM
Krenair claimed this task.May 6 2016, 4:25 PM

Change 287239 had a related patch set uploaded (by Alex Monk):
Add disclaimer message for steward contact form

https://gerrit.wikimedia.org/r/287239

@Trijnstel, @MarcoAurelio: If you guys are happy with the text it'll go into Extension:WikimediaMessages in that commit, and when that change gets deployed we'll be able to use to set up the form.

This text is good. Please proceed with implementation.

@Trijnstel, @MarcoAurelio: If you guys are happy with the text it'll go into Extension:WikimediaMessages in that commit, and when that change gets deployed we'll be able to use to set up the form.

@Krenair, @MarcoAurelio, @Ajraddatz: Yeah, definitely. Looks good.

Change 287239 merged by jenkins-bot:
Add disclaimer and title messages for steward contact form

https://gerrit.wikimedia.org/r/287239

So I think with that merged we should be good to go on Wednesday 13th, I'll schedule it for a SWAT window that day.

It'll have to be the "Evening" SWAT (to ensure metawiki will have the disclaimer message deployed, that's rolling with 1.28.0-wmf.10) which is actually past midnight into the next day in Europe.

Change 225509 merged by jenkins-bot:
Add basic contact form for stewards

https://gerrit.wikimedia.org/r/225509

Change 298899 had a related patch set uploaded (by Alex Monk):
Change steward contact form back to vform instead of ooui

https://gerrit.wikimedia.org/r/298899

Change 298899 merged by jenkins-bot:
Change steward contact form back to vform instead of ooui

https://gerrit.wikimedia.org/r/298899

Krenair closed this task as Resolved.Jul 13 2016, 11:19 PM
Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptAug 21 2017, 1:10 PM