Page MenuHomePhabricator

No logout button shown in stable
Closed, ResolvedPublic

Description


Is this intentional?

Event Timeline

Jdlrobson raised the priority of this task from to Needs Triage.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a project: Readers-Web-Backlog.
Jdlrobson moved this task to Incoming on the Readers-Web-Backlog board.
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2015, 5:30 PM
Jdlrobson renamed this task from No logout button shown to No logout button shown in stable.May 11 2015, 10:28 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson set Security to None.
Jdlrobson updated the task description. (Show Details)

Same for me in stable, beta and alpha :/

This is caused by SkinMinerva#flattenLinkArray not dealing with the input having more than one link, which the result of #getPersonalTools does.

… and the main menu template isn't written to handle multiple links with a single entry.

Looking at the tests…

Change 210301 merged by jenkins-bot:
Show the logout link

https://gerrit.wikimedia.org/r/210301

Change 211078 had a related patch set uploaded (by Phuedx):
Follow on Ibf1cea

https://gerrit.wikimedia.org/r/211078

Change 211078 merged by jenkins-bot:
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/211078

Change 212050 had a related patch set uploaded (by Kaldari):
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/212050

Change 212050 merged by jenkins-bot:
Support for cached menu data in HTML

https://gerrit.wikimedia.org/r/212050

phuedx closed this task as Resolved.May 20 2015, 1:34 PM
phuedx removed a project: Patch-For-Review.