Page MenuHomePhabricator

NullPointer (NullPointer)
Disabled

Projects

User does not belong to any projects.

User Details

User Since
Aug 14 2020, 12:12 AM (35 w, 3 d)
Roles
Disabled
LDAP User
NullPointer
MediaWiki User
Unknown
This account has been disabled.

Recent Activity

Aug 17 2020

NullPointer added a comment to T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.

Also, because I cannot clone from Gerrit I cannot commit to Gerrit, due to the internet connection.

Aug 17 2020, 7:39 AM · Pywikibot, Pywikibot-tests
NullPointer closed T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+ as Invalid.
Aug 17 2020, 7:37 AM · Pywikibot, Pywikibot-tests
NullPointer added a comment to T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.

In the setup.py I found a comment stating that this version of Pywikibot is not intended to run on python 2.7, so closing task.

VERSIONS_REQUIRED_MESSAGE = """
Pywikibot is not available on:
{version}
Aug 17 2020, 7:36 AM · Pywikibot, Pywikibot-tests

Aug 16 2020

NullPointer added a comment to T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.

I am working on it and I will submit a PR on Github

Aug 16 2020, 5:34 AM · Pywikibot, Pywikibot-tests
NullPointer added a comment to T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.

Actually, Python 2.7 to 3 have some major syntax changes, for example, stdin is read through the input() function, and XML-RPC lib must be changed for backwards compatibility.

input() is not a different syntax and that library is not used by the framework. My idea is to have a simple CI check to validate that both of these two scripts run still with Python 2.7 or 3.4. Any different behaviour of Python implementations does not care because a version check is made in setup.py as well as in pwb.py very early.

Aug 16 2020, 5:27 AM · Pywikibot, Pywikibot-tests
NullPointer raised the priority of T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+ from Lowest to Low.
Aug 16 2020, 3:30 AM · Pywikibot, Pywikibot-tests
NullPointer awarded T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+ a Manufacturing Defect? token.
Aug 16 2020, 3:30 AM · Pywikibot, Pywikibot-tests
NullPointer claimed T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.
Aug 16 2020, 3:26 AM · Pywikibot, Pywikibot-tests
NullPointer added a comment to T259991: pwb.py and setup.py should keep running with Python 2.7 and Python 3.4+.

Actually, Python 2.7 to 3 have some major syntax changes, for example, stdin is read through the input() function, and XML-RPC lib must be changed for backwards compatibility.

Aug 16 2020, 2:02 AM · Pywikibot, Pywikibot-tests

Aug 15 2020

NullPointer awarded T260281: mw* servers memory leaks (12 Aug) a The World Burns token.
Aug 15 2020, 11:17 AM · Wikidata, Platform Engineering, Sustainability (Incident Followup), SRE, serviceops
NullPointer added a comment to T260469: Add "ton of TNT" unit to the Wikidata conversion table to normalize values that uses this unit.

I do not know how to make pull requests with Gerrit, but the proposed changes are:

Aug 15 2020, 7:41 AM · Wikidata, Wikidata-Campsite, Wikidata-Query-Service
NullPointer claimed T260469: Add "ton of TNT" unit to the Wikidata conversion table to normalize values that uses this unit.

Claimed the task. I will work on it soon so this is high priority.

Aug 15 2020, 7:32 AM · Wikidata, Wikidata-Campsite, Wikidata-Query-Service

Aug 14 2020

NullPointer added a comment to T260281: mw* servers memory leaks (12 Aug).

I suggest setting this a security issue since this may cause people to intentionally make memory leaks to damage servers using this software.

Aug 14 2020, 11:02 AM · Wikidata, Platform Engineering, Sustainability (Incident Followup), SRE, serviceops
NullPointer added a comment to T260398: Request creation of a VPS project.

@Aklapper I stopped developing huggle.

Aug 14 2020, 10:56 AM · Cloud-VPS (Project-requests)
NullPointer added a comment to T260398: Request creation of a VPS project.

Oh. sorry for that I meant 1.34

Aug 14 2020, 1:49 AM · Cloud-VPS (Project-requests)
NullPointer added a comment to T260398: Request creation of a VPS project.

MW extensions and PYwikibot. Currently, only I will use this instance, but others may use this in the future.

Aug 14 2020, 1:28 AM · Cloud-VPS (Project-requests)
NullPointer added a comment to T260398: Request creation of a VPS project.

@bd808 This is not a laptop in the cloud. Although I stopped developing Huggle, I am developing Kiwix and MW extensions, and I need a VPS to test out.

Aug 14 2020, 1:18 AM · Cloud-VPS (Project-requests)
NullPointer created T260398: Request creation of a VPS project.
Aug 14 2020, 12:25 AM · Cloud-VPS (Project-requests)