Page MenuHomePhabricator

E8. LQT conversion sends email notifications for every single topic I've got unread notifications for
Closed, ResolvedPublic

Description

On June 24, I received 4 emails at my volunteer account, for old LQT threads (for which I had Unread Notifications) which had just been converted. The threads did not have new activity.
One of my CL colleagues had a similar problem.

From the remnant left in Special:NewMessages, I guess that this might be related to the two edits by Flow Talk Page Manager (FTPM). All other posts within the thread just had one edit by FTPM.


https://www.mediawiki.org/w/index.php?title=Thread:Extension_talk:Popups/Pop_Up_is_Stuck_in_Pop_Up&action=history

In my userpreferences, I have all Echo checkboxes enabled, and enotifwatchlist is disabled.


This is related to

Event Timeline

Quiddity created this task.Jun 27 2015, 8:13 PM
Quiddity raised the priority of this task from to High.
Quiddity updated the task description. (Show Details)
Quiddity added a subscriber: Quiddity.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 27 2015, 8:13 PM

Did you receive new email notifications for all the unread LQT topics, only some, or not sure (note it only creates one Flow notification per unread LQT topic)?

(The two edit thing is a minor bug that happens for all topics, but I haven't addressed it since it doesn't impact users, AFAICT.)

I received emails for all 4 threads that contained unread posts.
I cannot see any obvious patterns (e.g. I had contributed to some threads, and not contributed to others).

Mattflaschen-WMF renamed this task from LQT conversion sends notifications for every single topic I've got unread notifications for to LQT conversion sends email notifications for every single topic I've got unread notifications for.Jun 29 2015, 5:55 PM
DannyH renamed this task from LQT conversion sends email notifications for every single topic I've got unread notifications for to E8. LQT conversion sends email notifications for every single topic I've got unread notifications for.Jun 30 2015, 9:04 PM

Change 223695 had a related patch set uploaded (by Mattflaschen):
Never send email notifications for LQT notifications imported to Flow

https://gerrit.wikimedia.org/r/223695

Change 223695 merged by jenkins-bot:
Never send email notifications for LQT notifications imported to Flow

https://gerrit.wikimedia.org/r/223695

Change 223696 had a related patch set uploaded (by Catrope):
Never send email notifications for LQT notifications imported to Flow

https://gerrit.wikimedia.org/r/223696

Change 223696 merged by jenkins-bot:
Never send email notifications for LQT notifications imported to Flow

https://gerrit.wikimedia.org/r/223696

Partial list of testing suggestions:

  • Default setting (no Flow email notifications)
  • Flow email notifications enabled through preferences with default of 'As they come in' at top.
  • Other batching settings.

A batch can be sent out immediately (thus verifying that the notification was not queued) with Echo/maintenance/processEchoEmailBatch.php --ignoreConfiguredSchedule

All suggestions have been tested in Talk namespace. Unfortunately, I do not have old LQT pages in test.wikimedia.beta.wmflabs.org.

Is it expected behavior that the most recent of unread New messages(e.g. Replay on an LQT page), upon conversion to Flow is pushed to 'unread Message board' notifications and, accordingly, is displayed in red ?
No emails are sent though.

Is it expected behavior that the most recent of unread New messages(e.g. Replay on an LQT page), upon conversion to Flow is pushed to 'unread Message board' notifications and, accordingly, is displayed in red ?

Yes, all should be unread. Red color (unseen) is expected if the LQT message is dated after the last time you opened the flyout. That means it's treated as unseen, thus red.

I'm getting emails for LQT conversions today.
E.g. a link to https://www.mediawiki.org/w/index.php?title=Topic:Sdrcl7bwzm1z8nku&topic_showPostId=sdrcl7bwzm1z8nku&fromnotif=1#flow-post-sdrcl7bwzm1z8nku which I assume is for the 2 messages I'd left marked "unread" in this thread. (However, Flow has marked every post in the thread with the blue bar)
In preferences I have enotifwatchlist turned off, and all Echo prefs turned on.

DannyH closed this task as Resolved.Jul 10 2015, 5:35 PM
DannyH added a subscriber: DannyH.

It looks like maybe this was not deployed:

mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git reflog
2cea5b8 HEAD@{0}: rebase finished: returning to refs/heads/wmf/1.26wmf13
2cea5b8 HEAD@{1}: checkout: moving from wmf/1.26wmf13 to 2cea5b853c6e4d0173eb24c200361d392e8436f0^0
78db530 HEAD@{2}: checkout: moving from 78db53098beb7e88020ab62e43c0399158eb09df to wmf/1.26wmf13
78db530 HEAD@{3}: checkout: moving from master to 78db53098beb7e88020ab62e43c0399158eb09df
2e83436 HEAD@{4}: clone: from https://gerrit.wikimedia.org/r/p/mediawiki/extensions/Flow.git
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ 
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git log -1 --oneline master
2e83436 Merge "Make search API output very similar to view-topiclist"
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ 
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git log -1 --oneline 78db530
78db530 Creating new wmf/1.26wmf13 branch
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ 
mattflaschen@tin:/srv/mediawiki-staging/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git log -1 --oneline 2cea5b8
2cea5b8 urlencode titles in Parsoid URL

It went directly from master, to branch cut, to the URL-encode fix (but even when I deployed that, I still didn't deploy other files).

I have emails that are consistent with this bug:

Side note, what is wrong with the /srv/mediawiki git index on tin?

mattflaschen@tin:/srv/mediawiki/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git status
# On branch wmf/1.26wmf13
nothing to commit (working directory clean)
mattflaschen@tin:/srv/mediawiki/php-1.26wmf13/extensions/Flow (wmf/1.26wmf13)$ git diff --name-status HEAD:Hooks.php Hooks.php
M       Hooks.php