Convert LQT->Flow on se.wikimedia.org
Closed, ResolvedPublic

Description

Could the Extension:Flow please be activated on the Wikimedia Sverige chapter wiki (se.wikimedia.org)? We have LiquidThreads today.

As per the local extension policy there is no need for community support on this wiki.

Related Objects

StatusAssignedTask
ResolvedCatrope
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
Resolvedmatthiasmullie
ResolvedEBernhardson
Resolvedmatthiasmullie
ResolvedMattflaschen-WMF
Resolvedmatthiasmullie
ResolvedEBernhardson
ResolvedEBernhardson
ResolvedDannyH
ResolvedEBernhardson
DuplicateMattflaschen-WMF
ResolvedEBernhardson
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedNone
ResolvedEBernhardson
ResolvedEBernhardson
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedCatrope
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedMattflaschen-WMF
ResolvedSBisson
ResolvedSBisson
ResolvedSBisson
ResolvedSBisson
ResolvedMattflaschen-WMF
Ainali created this task.Jul 19 2015, 9:41 PM
Ainali updated the task description. (Show Details)
Ainali raised the priority of this task from to Needs Triage.
Ainali added a subscriber: Ainali.
Restricted Application added subscribers: Josve05a, Aklapper. · View Herald TranscriptJul 19 2015, 9:41 PM

Do you also want the existing LiquidThreads discussions to be converted to Flow?

Yes, if that is possible it would be very nice.

Mattflaschen-WMF renamed this task from Enable Extension:Flow on se.wikimedia.org to Enable Extension:Flow on se.wikimedia.org and convert LQT->Flow.Jul 28 2015, 2:38 AM
Mattflaschen-WMF set Security to None.
Mattflaschen-WMF added a subscriber: Mattflaschen-WMF.
DannyH triaged this task as Normal priority.Jul 29 2015, 11:35 PM
DannyH added a subscriber: DannyH.

That's great, I'm really glad you're interested! We'll be able to put up some initial pages on your wiki soon -- we'll have to figure out when we can do the LQT conversion.

Stryn added a subscriber: Stryn.Jul 31 2015, 5:09 PM
DannyH raised the priority of this task from Normal to High.Aug 20 2015, 8:34 PM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptAug 20 2015, 8:34 PM
Mattflaschen-WMF renamed this task from Enable Extension:Flow on se.wikimedia.org and convert LQT->Flow to Convert LQT->Flow on se.wikimedia.org.Aug 22 2015, 2:19 AM

It's now enabled, so updated accordingly.

Catrope lowered the priority of this task from High to Normal.Sep 1 2015, 5:55 PM
DannyH raised the priority of this task from Normal to High.Sep 21 2015, 9:23 PM

Setting this to High, we need to get this done before the end of the month.

Catrope claimed this task.Sep 30 2015, 12:07 AM

I've successfully converted https://se.wikimedia.org/wiki/Diskussion:N%C3%A4sta_dagordning as a test. The main conversion is now running.

The conversion is finished now. I'll post the logs later.

Ainali added a comment.EditedSep 30 2015, 1:16 PM

When I try to reply to a post, the top of the editing field says: "Error: One or more dependencies failed to load".

Change 242640 had a related patch set uploaded (by Mattflaschen):
Freeze LQT on Swedish Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/242640

Logs: P2130 P2131 P2129

Found no exceptions other than those caused by the accent bug, which didn't actually cause the import to fail but just broke writing the .sourceStore file afterwards.

Change 242640 merged by jenkins-bot:
Freeze LQT on Swedish Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/242640

Did a final run (and then a confirmation run after) immediately before freezing. One additional page was done.

mattflaschen@terbium:~$ mwscript extensions/Flow/maintenance/convertAllLqtPages.php --wiki=sewikimedia --debug --logfile=/tmp/2015-10-01-sewikimedia-full-final.sourceStore | tee ~/2015-10-01-sewikimedia-full-final.log
[2015-10-01 15:05:17] Considering for conversion: pages with the 'use-liquid-threads' property
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 1
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 3
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 5
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 7
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 9
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 11
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 13
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 15
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 101
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 2301
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 2303
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 91
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 93
[2015-10-01 15:05:17] Considering for conversion: pages in namespace 829
[2015-10-01 15:05:17] Starting full wiki LQT conversion of all LiquidThreads pages
[2015-10-01 15:05:23] Archiving page from Användardiskussion:Ximena Magdalena to Användardiskussion:Ximena Magdalena/LQT Archive 1
[2015-10-01 15:05:23] Importing to Användardiskussion:Ximena Magdalena
[2015-10-01 15:05:23] Workflow isNew: true
[2015-10-01 15:05:23] ensureFlowRevision status isOK: true
[2015-10-01 15:05:23] ensureFlowRevision status isGood: true
[2015-10-01 15:05:23] ensureFlowRevision already-existed: false
[2015-10-01 15:05:23] ensureFlowRevision revision ID: 53819, page ID: 9087
[2015-10-01 15:05:23] Importing header
[2015-10-01 15:05:24] Imported 2 revisions for header
[2015-10-01 15:05:24] Imported 1 items, failed 0
[2015-10-01 15:05:25] Completed import to Användardiskussion:Ximena Magdalena from Användardiskussion:Ximena Magdalena/LQT Archive 1
[2015-10-01 15:05:26] Finished conversion
mattflaschen@terbium:~$ mwscript extensions/Flow/maintenance/convertAllLqtPages.php --wiki=sewikimedia --debug --logfile=/tmp/2015-10-01-sewikimedia-full-final.sourceStore | tee ~/2015-10-01-sewikimedia-full-final.log
[2015-10-01 15:07:27] Considering for conversion: pages with the 'use-liquid-threads' property
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 1
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 3
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 5
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 7
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 9
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 11
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 13
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 15
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 101
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 2301
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 2303
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 91
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 93
[2015-10-01 15:07:27] Considering for conversion: pages in namespace 829
[2015-10-01 15:07:27] Starting full wiki LQT conversion of all LiquidThreads pages
[2015-10-01 15:07:33] Finished conversion
Mattflaschen-WMF added a comment.EditedOct 1 2015, 3:14 PM

Somehow the templates were not setup properly here (or maybe they changed?), even though we tried to do it on all production wikis. Example showing red link in description: https://se.wikimedia.org/wiki/Anv%C3%A4ndardiskussion:Ximena_Magdalena

I thought we did this by now, but evidently not: T111098: Run FlowCreateTemplates.php on all Flow-enabled wikis in production. Sorry I didn't think to mark it a blocker.

DannyH removed a subscriber: DannyH.Oct 5 2015, 10:43 PM

@Etonkovidova Sorry I missed your comment on IRC.

se.wikimedia.org is sewikimedia.

There's a pattern (e.g. Wikipedia ends with 'wiki' (but not all ones ending in 'wiki' are Wikipedia), Wiktionary ends in 'wiktionary', etc). However, you can always check by going to the site and running:

mw.config.get( 'wgDBname' )

in the JavaScript console.

  • T111098: Run FlowCreateTemplates.php on all Flow-enabled wikis in production - is done.
  • sewikimedia is listed in
select distinct(workflow_wiki) from flow_workflow;
Catrope closed this task as Resolved.Oct 7 2015, 10:58 PM
Catrope closed subtask T114277: Freeze LQT on se.wikimedia as Resolved.
Ainali added a comment.Oct 8 2015, 5:15 AM

Conversions of LQT to Flow seem to gone okay. But when you go to a page with no discussion yet, there is no Flow board there, example: https://se.wikimedia.org/w/index.php?title=Diskussion:Wikimedia_Sverige/en&action=edit&redlink=1

Change 245588 had a related patch set uploaded (by Catrope):
Flow-occupy all talk namespaces on sewikimedia

https://gerrit.wikimedia.org/r/245588

Conversions of LQT to Flow seem to gone okay. But when you go to a page with no discussion yet, there is no Flow board there, example: https://se.wikimedia.org/w/index.php?title=Diskussion:Wikimedia_Sverige/en&action=edit&redlink=1

It seems we forgot to enable "occupation" of talk namespaces on sewikimedia, sorry about that. It'll be enabled in 2-3 hours.

Change 245588 merged by jenkins-bot:
Flow-occupy all talk namespaces on sewikimedia

https://gerrit.wikimedia.org/r/245588

Change 245588 merged by jenkins-bot:
Flow-occupy all talk namespaces on sewikimedia

https://gerrit.wikimedia.org/r/245588

We had to roll that back because it broke LQT archives. I'll run the content handler maintenance script, then try again.

We had to roll that back because it broke LQT archives. I'll run the content handler maintenance script, then try again.

I ran populateContentModel.php with --table=revision and table=archive for all odd-numbered namespaces on sewikimedia, then deployed https://gerrit.wikimedia.org/r/245609 .

https://se.wikimedia.org/wiki/Diskussion:Wikimedia_Sverige/en now works as expected, and https://se.wikimedia.org/wiki/Diskussion:Kontor/F%C3%B6rslag/LQT_Archive_1 is no longer broken.