Page MenuHomePhabricator

D7. LQT->Flow import sometimes does not show all topics until action=purge is done
Closed, ResolvedPublic3 Story Points

Description

This issue (discussed at https://gerrit.wikimedia.org/r/#/c/202979/) is still happening occasionally. We should fix it before doing "Day 8" of T92303: Convert LQT pages on MediaWiki.org to Flow (tracking).

Event Timeline

Mattflaschen-WMF raised the priority of this task from to Needs Triage.
Mattflaschen-WMF updated the task description. (Show Details)
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 4 2015, 6:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
DannyH triaged this task as High priority.Jun 4 2015, 9:06 PM
DannyH moved this task from Untriaged to Near-Term Interest on the Collaboration-Team-Triage board.
DannyH added a subscriber: DannyH.
DannyH added a comment.Jun 4 2015, 9:09 PM

Okay. Should we put this ticket on the sprint board?

DannyH edited a custom field.Jun 16 2015, 6:12 PM
DannyH renamed this task from LQT->Flow import sometimes does not show all topics until action=purge is done to D7. LQT->Flow import sometimes does not show all topics until action=purge is done.Jun 16 2015, 7:23 PM

This seems to be easier to reproduce when logged out. I'm not sure which is significant, creating the topics logged out, or that the first view is logged out.

I can't seem to figure this out.

I know it's an intermittent problem caused by a premature cache-filling operation, and I know various secondary information like the keys, etc. but despite a lot of conditional breakpoints I can't figure out what triggers the premature cache-fill.

I'm ready to use a workaround, but I'm hoping it actually works. I'm concerned that if something like the job queue or a deferred update is triggering the premature cache fill (maybe due to slave lag), purging the cache won't really help. The cache would be empty at the end of the conversion operation (which I think it already normally is), but that doesn't necessarily prevent the job queue or something from doing a premature cache-fill.

So the best solution may be to trigger a cache fill ourselves.

Change 219602 had a related patch set uploaded (by Mattflaschen):
Fix topics not appearing reliably after LQT->Flow, before action=purge

https://gerrit.wikimedia.org/r/219602

Change 219602 merged by jenkins-bot:
Fix topics not appearing reliably after LQT->Flow, before action=purge

https://gerrit.wikimedia.org/r/219602

General check for LQT->Flow import and purge(on ttp://test.wikimedia.beta.wmflabs.org/wiki/) - all topics were timely&properly displayed.

DannyH closed this task as Resolved.Jun 24 2015, 1:21 AM