Page MenuHomePhabricator

MwTimeIsoFormatter forces time precisions to be displayed in English
Closed, ResolvedPublic

Description

See the FIXME in MwTimeIsoFormatter::getMessage

Event Timeline

Lydia_Pintscher raised the priority of this task from to Normal.
Lydia_Pintscher updated the task description. (Show Details)
Lydia_Pintscher added a project: Wikidata.
Lydia_Pintscher added subscribers: Lydia_Pintscher, hoo.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2015, 1:50 PM
hoo added a comment.Jul 1 2015, 2:19 PM

Just tested this locally: 21 January 2014 on my repo is displayed as 21. Januar 2014 on my German client wiki.

Izno added a subscriber: Izno.EditedJul 1 2015, 3:45 PM

The problem is being reported in regard to centuries specifically; see [[:d:WD:Contact the development team#Century dating—localization]]. (This does not mean there aren't issues with other dates as well.)

Izno added a comment.Jul 1 2015, 4:15 PM

And in fact, the issue may be related to the fact that German seems to be the only localization, so testing on a German client probably won't help identify if there are other problems.

hoo added a comment.Jul 1 2015, 5:12 PM

And in fact, the issue may be related to the fact that German seems to be the only localization, so testing on a German client probably won't help identify if there are other problems.

That's not the case, the problem here is that precisions aren't yet translated. MwTimeIsoFormatter::getMessage still forces English for them.

hoo renamed this task from localization of dates on the client (property parser function) to MwTimeIsoFormatter forces time precisions to be displayed in English.Jul 1 2015, 5:13 PM
hoo updated the task description. (Show Details)
hoo set Security to None.

And in fact, the issue may be related to the fact that German seems to be the only localization, so testing on a German client probably won't help identify if there are other problems.

That's not the case, the problem here is that precisions aren't yet translated. MwTimeIsoFormatter::getMessage still forces English for them.

Maybe. But even at that the ordinal is coming out in "German"--for example, as "12." instead of "12th"

hoo added a comment.Jul 1 2015, 9:21 PM

And in fact, the issue may be related to the fact that German seems to be the only localization, so testing on a German client probably won't help identify if there are other problems.

That's not the case, the problem here is that precisions aren't yet translated. MwTimeIsoFormatter::getMessage still forces English for them.

Maybe. But even at that the ordinal is coming out in "German"--for example, as "12." instead of "12th"

Well, the English version also is for example 3. century for the third century, so nothing special is being done for German.

UV added a subscriber: UV.Jul 1 2015, 9:27 PM
Nikki added a subscriber: Nikki.Jul 2 2015, 3:38 AM

hoo: It isn't displayed as 3. century for German though. See what I wrote on https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team#Century_dating.E2.80.94localization

Mbch331 added a subscriber: Mbch331.Jul 2 2015, 5:44 AM

And in fact, the issue may be related to the fact that German seems to be the only localization, so testing on a German client probably won't help identify if there are other problems.

That's not the case, the problem here is that precisions aren't yet translated. MwTimeIsoFormatter::getMessage still forces English for them.

Maybe. But even at that the ordinal is coming out in "German"--for example, as "12." instead of "12th"

Well, the English version also is for example 3. century for the third century, so nothing special is being done for German.

Evidently not (see Nikki above). But then aside from the translation issues, the "English" is just simply wrong, because in English (British, American, or otherwise), you'd never say "12. century." You'd say "12th century."

hoo added a comment.Jul 6 2015, 9:23 PM

hoo: It isn't displayed as 3. century for German though. See what I wrote on https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team#Century_dating.E2.80.94localization

Not true, it is. I test things before I post here, I'm not making stuff up…

Nikki added a comment.Jul 7 2015, 4:10 AM

Not true, it is. I test things before I post here, I'm not making stuff up…

It is now, so it must have very recently changed, because I'm not making stuff up either. It really was using 3 century for German on Wikidata and the German Wikisource a few days ago.

It's been a while ... is anything going on with this? Just wondering ...

hoo closed this task as Resolved.Aug 25 2016, 1:06 PM
hoo claimed this task.