Page MenuHomePhabricator

In the mobile Web wikicode editor, it is impossible to scroll, so it is impossible to save the edit
Closed, ResolvedPublic

Description

I am on Wikipedia, on the page en.m.wikipedia.org/wiki/user:Nnemo/Tests
I click the pencil, to edit the page.
I get the mobile Web wikicode editor (full of bugs).
I click just before the word scream.
The point clicked hides to the left, so I don't see the blinking cursor. This may be a bug in itself, by the way.
I try to scroll left. With one finger. With two fingers.
This is expected to scroll left.
This does not scroll.
It is impossible to scroll horizontally.

After my edit, I want to save my edit.
There is no button for saving my edit. See T98505.
I try to scroll upwards. This may bring the button Next for saving my edit. I try with one finger. With two fingers.
This is expected to scroll upwards.
This does not scroll.
Scrolling vertically is impossible.
So it is impossible to save my edit.

It would be nice to fix this bug.

A nice way to fix this bug — and many others — would be to give a standard form, instead of the JavaScript crap. Thus, the page would be accessible.

Thank you.

I have Safari on iOS 8 on an iPad Air 2 in landscape with the reading list open.

I encounter the bug on en.m.wikipedia.org and on en.m.wikipedia.beta.wmflabs.org.

Nnemo

Event Timeline

Nnemo created this task.Jul 25 2015, 9:16 AM
Nnemo raised the priority of this task from to Needs Triage.
Nnemo updated the task description. (Show Details)
Nnemo added a subscriber: Nnemo.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2015, 9:16 AM
Nnemo updated the task description. (Show Details)Jul 25 2015, 9:18 AM
Nnemo set Security to None.
Nnemo updated the task description. (Show Details)Jul 25 2015, 9:24 AM
Nnemo awarded a token.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptJul 25 2015, 12:37 PM

How is this bug different to T98505, isn't this an updated version? I should note the issue is a css issue and position fixed not with JavaScript.

A few questions:

  1. Debugging I see you left out a crucial piece of information... can you confirm you are in landscape mode and not portrait?
  2. In scenario 1 you expect to be able to horizontally scroll. Why? There is nothing to scroll.
  3. In scenario 1 I see a blinking cursor. Which specific version of ios are you using? 8.2? 8.3? 8.1?
  4. Can you confirm that you see the bottom of the save button? You are just unable to scroll up to it?

FYI, I'm not sure if this is intentional, but phrases such as "full of bugs" or "JavaScript crap" are not necessary and rude to the people who spend time writing this software, especially given how many people in T98505, including a volunteer, have had a go at fixing this difficult bug. Rather than do that, it would be great if you could help us fix this frustrating issue.

If you can provide answers to questions 1 and 4 I think I have a handle on this issue now.

Change 227344 had a related patch set uploaded (by Jdlrobson):
Disable fixed headers on overlays in ios 8

https://gerrit.wikimedia.org/r/227344

Okay the test article [1] proved very useful (thanks @Nnemo)
I managed to narrow it down to the 2 upstream bugs.

First issue was our blur event not firing in ios8 when you close the keyboard. I guess this is intended behaviour?
Secondly instead of self._resizeContent( $window.height() ); when firing the blur event you have to also subtract the height of the header.

I tried to find a satisfactory solution but failed so let's turn off the fixed header for ios 8. It's more trouble then it is worth.

[1] http://en.m.wikipedia.org/wiki/user:Nnemo/Tests

Would be great if someone could merge this pre deployment cut...!

Change 227344 merged by jenkins-bot:
Disable fixed headers on overlays in ios 8

https://gerrit.wikimedia.org/r/227344

Jhernandez closed this task as Resolved.Jul 29 2015, 9:54 AM

Works on testwiki, will rollout fully on Thursday then.

Nnemo added a comment.Aug 2 2015, 7:03 PM

How is this bug different to T98505, isn't this an updated version?

This issue is about scrolling being very difficult and often even impossible. This bug is very annoying, it has been occurring for months when editing Wikipedia. I will soon test again, you may have killed the bug now. :-) Impossible scrolling has the side-effect of making the button Next impossible to find. But this is just a side-effect.

The issue T98505 is about the button Next being missing. It occurs even when there is nowhere to scroll.

FYI, I'm not sure if this is intentional, but phrases such as "full of bugs" or "JavaScript crap" are not necessary and rude to the people who spend time writing this software, especially given how many people in T98505, including a volunteer, have had a go at fixing this difficult bug. Rather than do that, it would be great if you could help us fix this frustrating issue.

I understand that, I don't want to offend the developers, just the bugs. ;-) The bugs in this editor have been very annoying for me during months when editing Wikipedia.

I thank you for your work.

On the beta site, things are better now. :-)

Nnemo added a comment.Aug 2 2015, 8:14 PM

A few questions:

  1. Debugging I see you left out a crucial piece of information... can you confirm you are in landscape mode and not portrait?

Sure, my iPad is in landscape. And Safari has the reading list open, this narrows the view. I wrote this in the description of the task.

  1. In scenario 1 you expect to be able to horizontally scroll. Why? There is nothing to scroll.

There is some content to scroll. This may come from my reading list open, it reduces the view.

Scrolling horiz is even essential. When I first click just before scream, the blinking cursor comes hidden at the left, the view is too far right, so I first have to scroll left to see the beginning of the lines. I think that this annoyance comes from a bug that has appeared in Safari in iOS 8, but if you can do something about it that would be great. :-)

  1. In scenario 1 I see a blinking cursor. Which specific version of ios are you using? 8.2? 8.3? 8.1?

All three! I think I was using my iPad in iOS 8.1.2, but I have encountered this bug on several iPads, in iOS 8.1, 8.2 and 8.3.

  1. Can you confirm that you see the bottom of the save button? You are just unable to scroll up to it?

No. Now, I don't see the button Next at all.

But now I tested on en.m.wikipedia.org and fr.m.wikipedia.org and scrolling works! When I scroll up, I find the button Next.

FYI, I'm not sure if this is intentional, but phrases such as "full of bugs" or "JavaScript crap" are not necessary

You are right, they were not necessary. If people felt offended, then I am sorry, don't be offended.

First issue was our blur event not firing in ios8 when you close the keyboard. I guess this is intended behaviour?

Now, when I dismiss the keyboard, the button Next does not appear. I guess that this is consistent with what you have found.

I tried to find a satisfactory solution but failed so let's turn off the fixed header for ios 8. It's more trouble then it is worth.

Very good. The fixed header was a big thorn.

Thank you so much for fixing this bug! If all bugs were fixed so quickly, that would be wonderful!

Thank you @Nnemo for your thoughtful and understanding reply. This should be fixed now on all wikis, apologies it took so long to get to the bottom of and thanks for your patience. Please create a new task if you find any similar problems.