Page MenuHomePhabricator

action=mobileview doesn't return proper html for Special: pages
Closed, InvalidPublic

Description

There are complaints of the mobileview API not properly returning content for special pages.

From email in: https://lists.wikimedia.org/pipermail/mobile-l/2015-June/009351.html

Maybe related: T71984

Needs verification.

Event Timeline

Jhernandez raised the priority of this task from to Needs Triage.
Jhernandez updated the task description. (Show Details)
Jhernandez added subscribers: Jhernandez, dr0ptp4kt.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2015, 8:57 AM
Jdlrobson moved this task from Backlog to Discussing on the MobileFrontend board.Aug 4 2015, 6:30 PM

Not sure what this is about. @dr0ptp4kt can you explain?

Not sure. @Nemo_bis, would you please elaborate here on Phabricator re: https://lists.wikimedia.org/pipermail/mobile-l/2015-June/009351.html ?

Jdlrobson closed this task as Invalid.Sep 16 2015, 6:31 PM
Jdlrobson claimed this task.

A request against mobile view throws an error. It's not intended to do anything. It's not meant for special pages.

Reading through the e-mails it looks like the apps weren't special casing special pages. There is no bug in mobile view that I can relating to this discussion so I think this is a case of a misunderstanding. Please reopen with more exact instructions if there is a problem.

http://en.wikipedia.beta.wmflabs.org/wiki/Special:ApiSandbox#action=mobileview&format=json&page=Special%3ANearby