Page MenuHomePhabricator

Segfault while running mw-install-mysql.sh on trusty-1016
Closed, ResolvedPublic

Description

Error message:

14:30:32 + /srv/deployment/integration/slave-scripts/bin/mw-install-mysql.sh
14:30:33 /srv/deployment/integration/slave-scripts/bin/mw-install-mysql.sh: line 22: 29054 Segmentation fault (core dumped) php maintenance/install.php --confpath "$MW_INSTALL_PATH" --dbtype=mysql --dbserver="$MW_DB_HOST:$MW_DB_PORT" --dbuser="$MW_DB_USER" --dbpass="$MW_DB_PASS" --dbname="$MW_DB" --pass testpass TestWiki WikiAdmin

Full console output: https://integration.wikimedia.org/ci/job/mediawiki-extensions-qunit/9856/consoleFull
Associated patch: 235717

@hashar said to mention that the build ran on integration-slave-trusty-1016

Event Timeline

phuedx created this task.Sep 3 2015, 2:46 PM
phuedx raised the priority of this task from to Needs Triage.
phuedx updated the task description. (Show Details)
phuedx added subscribers: phuedx, hashar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 3 2015, 2:46 PM

That is HHVM core dumping :-(

$ php --version
HipHop VM 3.6.5 (rel)
Compiler: 1440023731_994787068
Repo schema: 10ff5b7278f68f074cfdefae238f379500d3148f
Extension API: 20150212

HHVM is up to date:

Installed: 3.6.5+dfsg1-1+wm3
Candidate: 3.6.5+dfsg1-1+wm3

I could not reproduce on the slave within the same workspace :-( The slaves do not capture core dumps (hhvm.debug.core_dump_report=false).

Looking at the job history, the job has been falling on integration-slave-trusty-1016 since 3 sept. 2015 01:18:07 UTC.

hashar added a comment.Sep 3 2015, 3:07 PM

Deleting /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit on integration-slave-trusty-1016 .

We will see what happens next time a job run there.

hashar closed this task as Resolved.Sep 3 2015, 3:13 PM
hashar claimed this task.

Triggered a build at https://integration.wikimedia.org/ci/job/mediawiki-extensions-qunit/9863/console It is busy cloning all repos and eventually passed.

I guess something went corrupt in the workspace :-(

Legoktm renamed this task from Segfault while running mw-install-mysql.sh to Segfault while running mw-install-mysql.sh on trusty-1016.Sep 3 2015, 3:15 PM
Legoktm set Security to None.
greg moved this task from INBOX to Done on the Release-Engineering-Team board.Sep 8 2015, 8:43 PM