[Regression] Editing upper post in nested thread opens all nested Replies
Closed, ResolvedPublic

Description

  1. Create Reply structure as in the screenshot, i.e. Reply to a topic and then create three replies for the first one by clicking at 'Reply' under the initial Reply

  1. Click on the upper most Reply to Edit. All nested Replies will be open with empty content. They cannot be canceled and the page needs to be refreshed. In the screenshot, see how the original Reply "test" is placed.

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added subscribers: Aklapper, Etonkovidova.

Change 237288 had a related patch set uploaded (by Catrope):
Don't open multiple editors when editing posts that have replies

https://gerrit.wikimedia.org/r/237288

Change 237288 merged by jenkins-bot:
Don't open multiple editors when editing posts that have replies

https://gerrit.wikimedia.org/r/237288

Change 237290 had a related patch set uploaded (by Catrope):
Don't open multiple editors when editing posts that have replies

https://gerrit.wikimedia.org/r/237290

Change 237290 merged by jenkins-bot:
Don't open multiple editors when editing posts that have replies

https://gerrit.wikimedia.org/r/237290

Checked in betalabs.

Checked in betalabs.

@Etonkovidova: If you checked, what was the result of your check?

Checked in betalabs.

@Etonkovidova: If you checked, what was the result of your check?

It passed. She will say if there is a failure. Also, you can tell because she moved it to Product Review, meaning QA Review is completed without finding problems.

DannyH closed this task as Resolved.Sep 14 2015, 5:31 PM
DannyH added a subscriber: DannyH.

I double-checked in Beta, this is fixed. :)