Page MenuHomePhabricator

Rename #Wikimedia-Git-or-Gerrit to #Gerrit and create #Gitblit
Closed, ResolvedPublic

Description

Created Differential

Similary, re-activated Diffusion (and cleaned it up).

And with these two created (I'm in the process of populating them with old tasks that should be in there), I propose to rename #Wikimedia-Git-or-Gerrit to Gerrit (and move out any tasks related to Diffusion or Differential, as appropriate).

Event Timeline

greg created this task.Sep 10 2015, 4:39 AM
greg updated the task description. (Show Details)
greg raised the priority of this task from to Needs Triage.
greg added a project: Project-Admins.
greg added a subscriber: greg.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 10 2015, 4:39 AM
greg added a comment.Sep 10 2015, 8:16 PM

I just took a quick (~1.5 minutes) look through all of the #Wikimedia-Git-or-Gerrit tasks and it looks like a rename to Gerrit would be sensible based on the content/purpose of the tickets. I take responsibility for re-triaging any tickets that are oddballs, if any.

hashar added a subscriber: hashar.EditedSep 10 2015, 9:12 PM

#Wikimedia-Git-or-Gerrit is used as a catch all for anything that is git related. That includes among other:

  • git support questions
  • Gerrit
  • gitblit/git.wikimedia.org
  • git-review
  • random tools using Gerrit API

I would rather triage Gerrit issue from #wikimedia-git-or-gerrit to a new Gerrit project. Then most probably mass decline / dispatch all the rest. Once there is no open bug we can archive the project, bugs that are closed would be left with it but that is good enough imho.

Or of course, rename it Gerrit and create another project #git-related to move stuff to :D

I created a "really gerrit" on the dashboard https://phabricator.wikimedia.org/project/sprint/board/330/ so we can potentially move true Gerrit issue there.

greg added a comment.Sep 10 2015, 9:21 PM

#Wikimedia-Git-or-Gerrit is used as a catch all for anything that is git related. That includes among other:

  • git support questions

That can stay there, but really aren't great for a task management system. It's not for support.

  • Gerrit

would stay, obviously

  • gitblit/git.wikimedia.org

going away, and/or we could make a Gitblit or #gitwikimediaorg project for them

  • git-review

would stay, since it's 'a part of' gerrit

  • random tools using Gerrit API

should be in their own project, unless the issue is with the gerrit api itself

I would rather triage Gerrit issue from #wikimedia-git-or-gerrit to a new Gerrit project. Then most probably mass decline / dispatch all the rest. Once there is no open bug we can archive the project, bugs that are closed would be left with it but that is good enough imho.

That sounds like extra work without a benefit to me.

Or of course, rename it Gerrit and create another project #git-related to move stuff to :D

:)

I created a "really gerrit" on the dashboard https://phabricator.wikimedia.org/project/sprint/board/330/ so we can potentially move true Gerrit issue there.

#Projects are cheap and help organize, workboards take more effort to manage and are kind of hidden and inconsistent.

I still strongly vote for renaming to Gerrit and use it only for gerrit (the vast majority are about gerrit) and moving others to their rightful place.

greg renamed this task from Rename #Wikimedia-Git-or-Gerrit to #Gerrit to Rename #Wikimedia-Git-or-Gerrit to #Gerrit and create #Gitblit.Sep 11 2015, 3:42 PM
greg set Security to None.

I think this change would be pretty minimally invasive (as described) and I'd like to do it by the middle of next week.

this change would be pretty minimally invasive (as described) and I'd like to do it by the middle of next week.

Appreciated! And big thanks (or rather my deep respect) for wading through all those tickets.

greg claimed this task.Sep 11 2015, 11:14 PM
Restricted Application added a project: User-greg. · View Herald TranscriptSep 11 2015, 11:14 PM
greg closed this task as Resolved.Sep 18 2015, 9:07 PM

I'd like to do it by the middle of next week.

Wrist pain delayed me. :(

{{DONE}}

Created:

  • Gitblit
  • GitHub-Mirrors (for that one task that was the oddball out, there might be more that are resolved, I haven't yet searched for those)

Renamed (but kept old name as an additional hashtag, to not break links): #/Wikimedia-Git-or-Gerrit to Gerrit

greg moved this task from Backlog to Done on the User-greg board.Sep 18 2015, 9:07 PM
greg added a comment.Sep 18 2015, 9:11 PM
  • GitHub-Mirrors (for that one task that was the oddball out, there might be more that are resolved, I haven't yet searched for those)

Re searching over closed tasks: I deem this not worth my time after doing a quick look, it'd take too much reading of the actual tasks instead of just the titles. Dwell not in the past, but look into the future.

Well done @greg thank you very much :-}

Re searching over closed tasks: I deem this not worth my time after doing a quick look, it'd take too much reading of the actual tasks instead of just the titles. Dwell not in the past, but look into the future.

I agree, not worth anyone time and that results in a spam of notifications to all subscribers on tasks that have been closed a long time ago.

It is not like we deal with medical records or money :-]