Page MenuHomePhabricator

trailing \n appearing at the bottom of search results pages on mediawiki.org and meta.wikimedia.org
Closed, ResolvedPublic

Description

Below the results, but above the navigation controls at the bottom of the page, a \n appears.

This does not appear to be happening on en.wikipedia.org.

I can also reproduce this issue locally using the tip of master:

Details

Related Gerrit Patches:
mediawiki/core : REL1_26Fix stray literal \n in output
mediawiki/core : masterFix stray literal \n in output
mediawiki/core : wmf/1.26wmf24Fix stray literal \n in output
mediawiki/core : masterFix trailing \n on Special:Search.

Event Timeline

Deskana created this task.Sep 23 2015, 8:04 PM
Deskana raised the priority of this task from to Medium.
Deskana updated the task description. (Show Details)
Deskana added a subscriber: Deskana.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 8:04 PM

Someone probably did '\n' instead of "\n"?

This seems to be caused by this patch: https://gerrit.wikimedia.org/r/#/c/238808/

Change 240590 had a related patch set uploaded (by EBernhardson):
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/240590

Change 240591 had a related patch set uploaded (by Deskana):
Fix trailing \n on Special:Search.

https://gerrit.wikimedia.org/r/240591

Okay, whoever reviews this can decide which of the two solutions is best. ;-)

Change 240590 merged by jenkins-bot:
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/240590

Change 240591 abandoned by Deskana:
Fix trailing \n on Special:Search.

Reason:
Unnecessary; Ia4591849f7675ad062210f21ff6273077a198704 was merged which fixed this problem.

https://gerrit.wikimedia.org/r/240591

Change 240596 had a related patch set uploaded (by Alex Monk):
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/240596

Change 240596 merged by Alex Monk:
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/240596

Krenair closed this task as Resolved.Sep 23 2015, 11:17 PM
Krenair claimed this task.
Krenair reassigned this task from Krenair to EBernhardson.
Krenair set Security to None.

Thanks for the backport and deploy, @Krenair!

Change 255654 had a related patch set uploaded (by Legoktm):
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/255654

Change 255654 merged by jenkins-bot:
Fix stray literal \n in output

https://gerrit.wikimedia.org/r/255654