Page MenuHomePhabricator

Remove usernames blocked at will from the mention search on Flow.
Open, Needs TriagePublic

Description

Sometimes, some troll create some accounts by adding some insults to an active username (a patroller or a sysop, most of the time). these accounts are usually banned.
When you want to mention someone on Flow, you search the username. You can have some not very complementary names: Trizek, Trizekyousuck, etc.
Is it possible to filter the username list to remove banned users from this list?
(Original request)

Event Timeline

Trizek-WMF raised the priority of this task from to Needs Triage.
Trizek-WMF updated the task description. (Show Details)
Trizek-WMF added subscribers: Trizek-WMF, Elfix, Kvardek_du.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 2 2015, 7:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ltrlg added a subscriber: Ltrlg.Oct 2 2015, 8:23 AM

You should be able to do that by suppressing/oversighting the user name, is that an acceptable solution?

Catrope closed this task as Declined.Oct 7 2015, 11:40 PM
Catrope claimed this task.

You should be able to do that by suppressing/oversighting the user name, is that an acceptable solution?

I don't think so. There is thousands of blocked users every day on all wikis, and they are creating a lot of noise on the suggestions lists.

Elfix added a comment.Oct 8 2015, 9:20 AM

In addition to this, I don't think all wikis agree that suppressing abusive usernames is the right solution. Suppression hides a part of the history and logs to everyone, sysops included, who cannot fully participate in the counter-vandalism efforts.

Howabout making all blocked users in a more transparent color in the list, like grey instead of black or something.

I don't think so. There is thousands of blocked users every day on all wikis, and they are creating a lot of noise on the suggestions lists.

Some of those users are only temporarily blocked, and it may be quite appropriate to mention a temporarily blocked user.

We already have a specific 'hideuser' right, and associated action. You're asking to let people without 'hideuser' hide user names in a specific place.

If we decided to do this, I think it would have to be only for indef-blocked users.

You can have some not very complementary names: Trizek, Trizekyousuck, etc.

This is exactly a use case for hideuser.

Trizek-WMF reopened this task as Open.Oct 9 2015, 12:35 PM
In T114467#1713173, @Mattflaschen wrote:

I don't think so. There is thousands of blocked users every day on all wikis, and they are creating a lot of noise on the suggestions lists.

Some of those users are only temporarily blocked, and it may be quite appropriate to mention a temporarily blocked user.
We already have a specific 'hideuser' right, and associated action. You're asking to let people without 'hideuser' hide user names in a specific place.
If we decided to do this, I think it would have to be only for indef-blocked users.

You can have some not very complementary names: Trizek, Trizekyousuck, etc.

This is exactly a use case for hideuser.

I don't understand if this solution is automated or not?

I don't understand if this solution is automated or not?

It is functionality already available to certain users. See #3 at https://en.wikipedia.org/wiki/Wikipedia:Oversight#Operation and "Hide username from edits and lists" at https://www.mediawiki.org/wiki/Help:Blocking_users .

Okay. But this requires an action to oversight a username, right?
As @Elfix explains here T114467#1711869, there is no consensus to hide usernames globally.

Okay. But this requires an action to oversight a username, right?

Yes.

As @Elfix explains here T114467#1711869, there is no consensus to hide usernames globally.

That's fine. But I don't think Flow should handle this differently than the many other places usernames are displayed.

In T114467#1774904, @Mattflaschen wrote:

That's fine. But I don't think Flow should handle this differently than the many other places usernames are displayed.

The problem is there is no other places where usernames are suggested when you type one to mention someone. :)

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 16 2015, 8:30 PM
Jdforrester-WMF removed Catrope as the assignee of this task.Mar 28 2017, 4:20 PM