Page MenuHomePhabricator

Set Western Arabic numerals on Arabic Wikipedia
Closed, DeclinedPublic

Description

We voted in Arabic Wikipedia for the exclusive use of Western Arabic numerals (WAN) (0, 1, 2 ) instead of allowing the use of Eastern Arabic numerals (EAN) (٠‎ - ١‎ - ٢) when editing.
21 for / none against
https://ar.wikipedia.org/wiki/%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7:%D8%A7%D9%84%D9%85%D9%8A%D8%AF%D8%A7%D9%86/%D8%B3%D9%8A%D8%A7%D8%B3%D8%A7%D8%AA/10/2015

And the related policy have been updated
https://ar.wikipedia.org/w/index.php?title=%D9%88%D9%8A%D9%83%D9%8A%D8%A8%D9%8A%D8%AF%D9%8A%D8%A7%3A%D8%AF%D9%84%D9%8A%D9%84_%D8%A7%D9%84%D8%A3%D8%B3%D9%84%D9%88%D8%A8&type=revision&diff=17231844&oldid=16952006

What we need now can be made with 3 tasks

First task : make a change from the roots
Each time we see a new project in Arabic or a major update, we face the same problem : Eastern Arabic numerals are used automaticcaly (see for example the date in the page in Arabic wikipedia https://ar.wikipedia.org/w/index.php?title=%D8%A7%D9%84%D9%85%D8%A8%D8%B9%D9%84_%28%D9%8A%D8%A7%D9%81%D8%B9%29&action=history). So we ask for a change manually. It was the case, for example, in Wikiversity (T31796) and it seems that we are facing the same problem in Wikidata (see the Arabic version of the project https://www.wikidata.org/wiki/Wikidata:%D8%A7%D9%84%D8%B5%D9%81%D8%AD%D8%A9_%D8%A7%D9%84%D8%B1%D8%A6%D9%8A%D8%B3%D9%8A%D8%A9). Please try to fix the problem from the source and for the existent and future Arabic projects.

Second task :script to help readers using Eastern Arabic numerals
In the discussion of the vote, someone said that it is possible to automatically change E to W numerals when saving the edits. Can you really add this feature to Arabic projects ? Some editors (specially those editing from cellphones) still use the EAN. If not, we are going to use a bot to periodically change numerals and make some exceptions (articles about the Indian numbering system, .. ).

third task : redirect in the search box
Actually, if someone make a search about an article that contains numerals and words but uses EAN, the article in WAN will not apparear.
As an example : when we make a search for an indian movie called https://en.wikipedia.org/wiki/Love_Story_2050 in Arabic wikipedia with EAN, and may be the problem is in other sister projects, the article doesn't appear in the search results.
https://ar.wikipedia.org/w/index.php?search=%D9%82%D8%B5%D8%A9+%D8%AD%D8%A8+%D9%A2%D9%A0%D9%A5%D9%A0+%28%D9%81%D9%8A%D9%84%D9%85+%D9%87%D9%86%D8%AF%D9%8A%29&title=%D8%AE%D8%A7%D8%B5%3A%D8%A8%D8%AD%D8%AB&go=%D8%A7%D8%B0%D9%87%D8%A8

Even in the article about the movie really exist but with WAN.
https://ar.wikipedia.org/wiki/%D9%82%D8%B5%D8%A9_%D8%AD%D8%A8_2050_%28%D9%81%D9%8A%D9%84%D9%85_%D9%87%D9%86%D8%AF%D9%8A%29

Thank you a lot. We hope that this time the problem with numbers in Arabic projects will be definitively closed.

Event Timeline

Helmoony created this task.Oct 15 2015, 4:43 AM
Helmoony raised the priority of this task from to Normal.
Helmoony updated the task description. (Show Details)
Helmoony added a subscriber: Helmoony.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 15 2015, 4:43 AM
revi updated the task description. (Show Details)Oct 15 2015, 9:16 AM
revi added a subscriber: revi.
revi added a comment.Oct 15 2015, 9:19 AM

Include only one problem per report

You should only have one thing to do in one task.

Aklapper renamed this task from Western Arabic numerals in all Arabic projects to Set Western Arabic numerals on Arabic Wikipedia.Oct 15 2015, 9:23 AM
Aklapper raised the priority of this task from Normal to Needs Triage.
Meno25 added a subscriber: Meno25.Oct 15 2015, 12:00 PM

Include only one problem per report

You should only have one thing to do in one task.

Helmoony here is requesting three different things:

Task 1:

MediaWiki should use Western Arabic Numerals (0 1 2 3 4 5 6 7 8 9) instead of Eastern Arabic Numerals (٠ ١ ٢ ٣ ٤ ٥ ٦ ٧ ٨ ٩) by default for wikis that use Arabic as the content language (Old 2005 discussion, New 2015 discussion)
I believe this can be done by setting $wgTranslateNumerals = false
This is easier for us (Arabic Wikimedians) instead of filing a new task to change the numeral system for every new Arabic Wikimedia project that gets created.

Task 2:

Write a script that automatically converts Eastern Arabic Numerals (EAN) to Western Arabic Numerals (WAN). So, the user types EAN in the edit box but the numbers gets saved in the wiki as WAN.

Personally, I believe that this can be done by a gadget that is enabled by default for all users.

Task 3:

The search engine should recognize EAN as equivalent to their WAN counterparts without having to create on-wiki-redirects that use EAN in the title.

Example:
When a user types "قصة حب ٢٠٥٠ (فيلم هندي)" in the search box, the search engine should automatically detect that "٢٠٥٠" (in EAN) is equivalent to "2050" (in WAN) and redirect the user to the correct title which is قصة حب 2050 (فيلم هندي) without having to actually create an on-wiki-redirect that contains EAN in the title.

@Helmoony I believe that it is better to split this request to 3 separate tasks to make it easier to follow-up.

Helmoony added a comment.EditedOct 15 2015, 1:05 PM

@Meno25, thank you for your comments. Yes, it's better to split it in 3 tasks (in the way you mentioned) since they are not linked.
@Aklapper, as Meno25 said, it's better to fix the problem for Mediawiki and not only for Wikipedia. We don't have a seperate community in Arabic sister projects (we don't have communities at all). All sysops for sister projects are active wikipedians.
@revi And yes, I definetively need to read more about phabricator ;)

Hi, who can split the tasks ?

The split is done ;) : T117215 T117216 T117217 .

Aklapper closed this task as Declined.Oct 30 2015, 4:10 PM
Aklapper claimed this task.

Thank you!

FShbib added a subscriber: FShbib.Mar 26 2016, 1:02 PM