Page MenuHomePhabricator

Outreachy proposal for T73660: Add ZIM format support to OCG
Closed, InvalidPublic

Description

This is a draft of a proposal

Profile
Name: Marya Sawaf
Email: sawafmarya@gmail.com
IRC or IM networks/handle(s): Minervax
Web Page / Blog / Microblog / Portfolio: https://ca.linkedin.com/pub/marya-sawaf/47/494/887
Resume (optional):
Location: Montreal, Canada
Typical working hours: 8am to 5pm

Synopsis
OCG allows users to take their collections and wikis hosted on MediaWiki (the wiki platform used in Wikipedia) and generate one file that looks like a book. Current support is for PDF files and plain text, and this project aims to allow ZIM file support to the book creator, which can be read on open-source file readers such as Kiwix.

Deliverables
Have Zim be a supported file format in the menu during export of a book: https://www.mediawiki.org/wiki/Special:Book

KeydateTaskDeliverable
Nov 2Given an article and an API URL, code a function able to download the list of JS and CSS dependenciesA tool in NodeJS to do the function
Nov 7Outreachy selection and team bondingFun!
Dec 10Merge Nodejs code into OCGSubmit patch to OCG
Dec 13Merge Nodejs code into MWofflinerSubmit patch to MWoffliner
Dec 17Complete T114788Get feedback and integrate changes
Feb 30T69540Not sure what this involves yet - Investigating (T113736)
March 30Include stylesheets and javascript in `mw-ocg-bundler'Not sure what this involves yet - Investigating
April 30Create Debian package for zimwriterfs.deb file
Extra timePerhaps begin coding the book creator for Django-wiki (personal interest!)TBD

Participation

  • I plan on being online in IRC as minervax or minervala, specifically in #mediawiki-parsoid
  • I will post all weekly summaries and reports on my github account or a gerritt repo (any suggestions?)
  • Any specific documentation to OCG

About me and past experiences

I love everything about information, knowledge-sharing and open access. I am a former lawyer, and I have completed a year of computer science at McGill University. I hope to begin a Masters in Library and Information Science next September.

I am specifically interested in computer-assisted knowledge discovery, search engines and information retrieval. I hope to host a talk at the 2016 Code4lib conference called "Brute Force Query Expansion based on Dbpedia", which allows research to be broadened with the use of both abstract and granular search terms. In the future, I want to eventually integrate this code into the Wikipedia visual editor to help editors achieve a more complete and balanced perspective on the entries they are writing and editing. But before starting such an ambitious project, I would like to get involved in a more straightforward way through this proposal, and improve my javascript skills throughout.

I am also interested in visualizations of data and want to get familiar with d3.js. All these things require javascript and this proposal is a great opportunity for me to learn!

My past experiences include a lot of web design ( Makerspace Canada , Amaradev, are recent examples.) I'm also working on a search engine for students looking for maker projects, it is an incomplete project Yureeka. I have done a university project for visualizing patient waiting times on a doctor portal at a local hospital (mySQL, Python, Matlab, numpy were used).

I am currently strong on Python and object-oriented programming, as well as HTML, CSS. My intermediate skills are Javascript and Java, SPARQL, mySQL and noSQL, Natural Language Processing (tools and libraries like Stanford NLP, NLTK) .

Event Timeline

Minervaxox claimed this task.
Minervaxox raised the priority of this task from to Normal.
Minervaxox updated the task description. (Show Details)
Minervaxox updated the task description. (Show Details)Oct 19 2015, 6:40 PM
Minervaxox set Security to None.
Minervaxox updated the task description. (Show Details)Oct 19 2015, 6:53 PM
Minervaxox added subscribers: cscott, Kelson.EditedOct 22 2015, 1:09 PM

@cscott @Kelson, Hi guys, I'm currently working on my patch and hope to have a submission for you by next mid-week. I had a question about the project in general - do you really think it will take 3-4 months to complete? I thought maybe 2 weeks, but I always underestimate these things. Is there anything else in OCG you'd like to add as a task? I mentioned I could work on making a django-wiki extension for OCG if I had extra time. Is this something that you think is interesting/important?
Thanks for your feedback!

@Minervavox
Sorry for the late answer and thank you very much for proposing to work on this task.

The problem is that we have an other developer, her name is Adisha, wanting to work on this task and already working on it:
https://phabricator.wikimedia.org/T116482

I'm puzzled by this situation which is new to me... Do you want to compete with Adisha? Is that something we want?

@Kelson Technically there can be more than one proposal per task since Outreachy will select based on availabilities too . Anyhow, I will close my proposal and work on something different. Good luck.

We are approaching the Outreachy'11 application deadline, and if you want to have your proposal considered to be part of this round, do sign up and add your proposal at https://outreachy.gnome.org/ before November 02 2015, 07:00 pm UTC. You can copy-paste the above proposal to the Outreachy application system, and keep on polishing it over here. Keep in mind that your mentors and the organization team will be evaluating your proposal here in Phabricator, and you are free to ask and get more reviews complying https://www.mediawiki.org/wiki/Outreach_programs/Life_of_a_successful_project#Answering_your_questions

@Minervaxox : I was just going through the Outreachy application system, and I couldnt find your proposal there ( even thought it has a nice copy here ). In case this was due to a mis-understanding of @Kelson' s comment here : https://phabricator.wikimedia.org/T115907#1759319 - please let one of us know. Every eligible participant has the right to submit their proposal before the application deadline, and the administration team including mentors and co-mentors are supposed to keep the gate open till then.

Minervaxox added a comment.EditedNov 5 2015, 1:25 PM

@01tonythomas Yeah, I started working on the code but wasn't getting much for replies or interest, so I decided to leave it to the other Outreachy student. Next time! Thanks for reaching out.

Mvolz added a subscriber: Mvolz.Nov 5 2015, 5:53 PM
01tonythomas closed this task as Invalid.Nov 8 2015, 9:24 AM

Closing this one as Invalid, as the proposal didnt make it to the Outreachy application system. Great work btw, @Minervaxox - and all the best for the next round of Outreachy/GSoC. Thank you!