Page MenuHomePhabricator

Name of Central Kurdish (ckb) language in language links was changed from "کوردی" to "کوردیی ناوەندی"
Closed, ResolvedPublic

Description

Hi. Someone changed ckb interwiki link without community permission. I discussed this subject with the community on village pump. They were all opposed to this change. Please change back the interwiki link to the "کوردی". Thank you.

Village pump discussion:
https://ckb.wikipedia.org/wiki/ویکیپیدیا:دیوەخان_(جۆراوجۆر)#.D8.A8.DB.95.D8.B3.D8.AA.DB.95.D8.B1.DB.8C_.D8.B2.D9.85.D8.A7.D9.86

Event Timeline

Calak created this task.Oct 27 2015, 2:58 PM
Calak raised the priority of this task from to Normal.
Calak updated the task description. (Show Details)
Calak added a subscriber: Calak.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 27 2015, 2:58 PM

Someone changed ckb interwiki link without community permission.

Changed to what exactly? Steps to reproduce are welcome.

Aklapper raised the priority of this task from Normal to Needs Triage.Oct 27 2015, 3:12 PM
Calak added a comment.Oct 27 2015, 3:33 PM

Someone changed it from "کوردی" to "کوردیی ناوەندی". Please change back it to the "کوردی".

Steps to reproduce are welcome.

^ As far as I know interwiki links cannot contain spaces but کوردیی ناوەندی does. So I'm not sure if we are talking about the same thing here...

Calak added a comment.Oct 27 2015, 3:57 PM


Look to uploaded picture; i talk about the red rectangle. Please change back it to the "کوردی".

Calak added a comment.Oct 27 2015, 6:11 PM

I found the problem. As you can see this change is without any community permission. Please change back it.

https://gerrit.wikimedia.org/r/#/c/209672/

Calak set Security to None.Oct 27 2015, 6:13 PM
Calak added a subscriber: Amire80.
Aklapper renamed this task from Change interwiki link on ckb wikipedia to Change name of Central Kurdish (ckb) language in language links.Oct 27 2015, 6:55 PM

Could you provide some references, especially as there seem to be several Kurdish languages according to ISO-639 and https://en.wikipedia.org/wiki/Kurdish_languages ?
https://en.wikipedia.org/wiki/Central_Kurdish states کوردیی ناوەندی .

Note that language names might not be an area that requires community consensus to change...

Calak added a comment.Oct 27 2015, 7:50 PM

"کوردیی ناوەندی" is translation of English phrase "Central Kurdish". We don't call our language "کوردیی ناوەندی". We call our language "Sorani" (سۆرانی) or "Kurdi" (کوردی).

Look to this link and check "Alternate Names" section:
http://www.ethnologue.com/language/ckb

Language links are based on local name not English name. For example language link of "South Azerbaijani" (AZB) is "تۆرکجه" which literally means Turkish. Or language link of "Western Punjabi" (PNB) is "پنجابی" means only Punjabi.

Epine added a subscriber: Epine.Jun 27 2017, 11:44 AM

Are we going to dismiss this issue just like this?

First of all, I've got to apologize about two things:

  1. About merging the patch without checking with somebody who speaks the language.
  2. About not taking proper care of this bug until today.

So, I'm sorry.

With that said, I won't insist specifically on "کوردیی ناوەندی", and I'm OK with changing it to something else, but I do have a few questions before we do it.

The word "کوردی" is just "Kurdi", so in a list of languages it may be hard to distinguish it from other Kurdish languages. ku is also just "Kurdî", albeit in the Latin alphabet, but from what I understand, the difference is not only in the alphabet, but in other characteristics of the language. It would be better to change it to a name that is clearly distinct. (And yes, it would be good to change ku from "Kurdî" to something more distinctive, too.)

Is it possible to use "سۆرانی" (Sorani) or maybe something like "کوردی سۆرانی" (Kurdi Sorani) instead of just "کوردی"?

First of all, I've got to apologize about two things:

  1. About merging the patch without checking with somebody who speaks the language.
  2. About not taking proper care of this bug until today.

So, I'm sorry.
With that said, I won't insist specifically on "کوردیی ناوەندی", and I'm OK with changing it to something else, but I do have a few questions before we do it.
The word "کوردی" is just "Kurdi", so in a list of languages it may be hard to distinguish it from other Kurdish languages. ku is also just "Kurdî", albeit in the Latin alphabet, but from what I understand, the difference is not only in the alphabet, but in other characteristics of the language. It would be better to change it to a name that is clearly distinct. (And yes, it would be good to change ku from "Kurdî" to something more distinctive, too.)
Is it possible to use "سۆرانی" (Sorani) or maybe something like "کوردی سۆرانی" (Kurdi Sorani) instead of just "کوردی"?

Amir, the Kurdi branch of Wikipedia uses Latin alphabets and it's an entirely different dialect than Sorani Kurdish. I personally see no problem with کوردی سۆرانی, and find it way better than "کوردی ناوەندی" which is an exact translation of what the English call it. Anyway, I'm going to alert Calak, the creator of the page, which is also an administrator on CKB, to see if he still persists on this change. Until then I do not advise any independent changes. Thanks.

Epine added a comment.Jun 27 2017, 3:26 PM

The community are persistent that the name must be changed back to (کوردی). This is based on consensus. Please change it back to that ASAP. thanks.

But what about making it different?

Epine added a comment.Jun 27 2017, 4:18 PM

No, as I've already said, we discussed this matter already and you're binding the rules by trying to intervene with the consensus. We have reached the conclusion it should be just "کوردی". Please change it back, thank you.

So how is a person who sees two languages with the same name will know which one to click?

Epine added a comment.Jun 27 2017, 5:27 PM

Kurmanji Kurdish is written in Latin letters, which means if someone is speaking kurmanji Kurdish they will click on the Latin Kurdi. Only the ones speaking Sorani Kurdish write in Arabic letters, however I feel that you are somehow trying to intervene with the community which is not a good dicision considering that you changed our Wikipedia without asking us first, now if you may, please change it back to the way it was before. Thanks.

I am not trying to intervene in anything. Please don't try to guess my intentions, I am explaining them very clearly.

Both Kurmanji and Sorani can be written in Latin and Arabic alphabets, so the name must be different.

Epine added a comment.Jun 27 2017, 6:28 PM

No, I'm an actual speaker of the language so what exactly are you talking about? No, Sorani Kurdish is not written in Latin! There's not a single article on CKB written in Latin letters!
I'm telling you that we have consensus, so why are you insisting on your invalid points and trying to prove a point that is false and doesn't exist?!

It is not written in Latin in the ckb Wikipedia, but it is sometimes written in Latin in real life. And Kurmanji Kurdish is sometimes written in the Arabic letters, so it should be renamed, too.

Epine added a comment.EditedJun 27 2017, 6:45 PM

What is "real life"? No, our language dialect is officially written in Arabic letters and Kurmanji is in Latin. You changed this without community permission and we are all against it, if you keep insisting on your false point I'm going to ask you please stop replying to any of our threads because you clearly have some problem with us and are trying to create diversity within our community. There is no renaming, we are Kurds and Kurdi is our language. This is community consensus on both CKB and KU wiki. I'm asking you to fix the mistake that you have made without wasting our time any longer.

@Epine: Hey, I'm admin from Persian Wikipedia and want to help here, please stay civil and polite, we want to resolve this issue and also this project is covered by Code of Conduct and violating that can cause ban, so if you want to get this fixed, please be polite.

I suggest we move forward "کوردی سۆرانی" for now.

Change 361790 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/core@master] Rename ckb to Soorani Kurdish

https://gerrit.wikimedia.org/r/361790

Epine added a comment.Jun 28 2017, 8:57 AM

@Ladsgroup I have stayed polite all this time but the fact that none of you listen when I say that the community has decided from both sides that it should be just "کوردی" and all of you ignore it and still do what you want anyway, means that actually you guys are the problem here. I didn't mean any disrespect in my previous comments and apologize for the attitude but please cancel Amir's changes as it was done independently and without asking our community first, which are all against this change and they remain the same for years!

Epine added a comment.Jun 28 2017, 9:02 AM

@Ladsgroup, to add to that, everything I said in my comments were right and none of the statements I made was for insulting or uncivilized reasons. Changing this settings has caused problems and disturbs our community, we asked Amir in 2015 to cancel his changes because it is done without asking the Wikipedia community. If I broke one single rule he broke the entire Wikimedia Foundation rules. Anyway, my apologies for any uncertain behavior coming from me.

(Just to set the record straight: I didn't make the change two years ago. I only reviewed it.)

@Epine: In addition to what Ladsgroup wrote above, please see https://www.mediawiki.org/wiki/Bug_management/Phabricator_etiquette . There is no reason to take things to a personal level or accuse specific people of "breaking WMF rules" (if there are, please provide specific links to prove your statements), etc.
Thanks for keeping discussions on Phabricator civil and respectful.

Epine added a comment.EditedJun 28 2017, 4:14 PM

@Aklapper see https://en.wikipedia.org/wiki/Wikipedia:Consensus
Wikipedia works on consensus. So why is it that you work independently here? That's breaking the rules. Thanks.

Epine triaged this task as Unbreak Now! priority.Jun 28 2017, 4:24 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJun 28 2017, 4:24 PM
Ghybu added a subscriber: Ghybu.Jun 28 2017, 4:43 PM

Hello,

The use of "کوردی/Kurdî" is also (I don't go back on the others arguments) justified by the fact that the Kurdish newspapers or the official websites use this method for to switch from Kurmancî to Soranî. For example, see

Epine added a comment.Jun 28 2017, 5:37 PM

@Ghybu yes, thank you, I've already covered that up in one of my comments saying they will recognize which is which. I don't know why they still oppose the right decision...

Aklapper renamed this task from Change name of Central Kurdish (ckb) language in language links to Name of Central Kurdish (ckb) language in language links was changed from "کوردی" to "کوردیی ناوەندی".Jun 29 2017, 10:06 AM
Aklapper lowered the priority of this task from Unbreak Now! to Normal.Jun 29 2017, 10:12 AM

@Epine: Please do not change priority of tasks that you do not work on yourself.

@Aklapper see https://en.wikipedia.org/wiki/Wikipedia:Consensus
Wikipedia works on consensus. So why is it that you work independently here? That's breaking the rules. Thanks.

This task is not about English Wikipedia or the guidelines on English Wikipedia. (Generally speaking and just for your info, it is not always that simple.)
Please discuss in a civil and respectful way by sticking to the topic of name and script of the language and replying to arguments made, by criticizing ideas but not people.

@Aklapper okay, but could you guys please fix this issue once and for all? There is no reason for this to go unfixed for years. This case was opened in 2015. What does it take for it to be fixed? We have proof to back us up, consensus, and everything, but ignoring the subject won't fix this issue. I've already been told that and apologized for any unnecessary comments that were not related to the topic.

FWIW: I made a patch that renames ckb name to "کوردی سۆرانی". It just need merge and deploy

@Ladsgroup, we don't need کوردی سۆرانی! We just ask for کوردی! Please proceed with the request!

@Ladsgroup, we don't need کوردی سۆرانی! We just ask for کوردی!

See T116761#3381871 for why we'd like some differentiation.
See T116761#3381896 where it was stated that no problem is seen with کوردی سۆرانی.

Ghybu added a comment.Jun 30 2017, 3:44 PM

In T116761#3395148, @Aklapper wrote:

See T116761#3381871 for why we'd like some differentiation.

See T116761#3387578 the answer for the non-necessity of this differentiation (Method used by newspapers and official organizations).

See T116761#3381896 where it was stated that no problem is seen with کوردی سۆرانی.

Here Epine speaks in a personal capacity (I personally [...]): this is the beginning of the discussion.
See T116761#3382700 his answer after community consultation.

Epine added a comment.EditedJun 30 2017, 7:08 PM

@Aklapper, it seems that @Ghybu answered this misunderstanding before I could, and it's exactly what I would have said. I said that I personally don't see a problem, but that was before I talk to the other guys, and I discovered that there is in fact many problems with that. That's why I said I don't recommend any independent actions. There is no reason that this discussion should continue furthermore. I honestly don't see why we should argue about something that's already resolved in the communities, we just simply ask to correct this mistake please. Thanks, again.

Calak added a comment.Jul 2 2017, 12:37 PM

@Amire80 Please merge Ladsgroup patch (https://gerrit.wikimedia.org/r/361790), we waited two years for this! Thank you.

Hello,
The use of "کوردی/Kurdî" is also (I don't go back on the others arguments) justified by the fact that the Kurdish newspapers or the official websites use this method for to switch from Kurmancî to Soranî. For example, see

Thanks for these examples.

If other websites do it like this, and the readers in these languages are accustomed to this practice, then I guess it can be done in MediaWiki as well.

I'm going to merge @Ladsgroup's patch.

Change 361790 merged by jenkins-bot:
[mediawiki/core@master] Rename ckb to Kurdish

https://gerrit.wikimedia.org/r/361790

Epine closed this task as Resolved.Jul 22 2018, 12:54 PM