Page MenuHomePhabricator

Flow UI does not allow replying to the last comment (it only allows reply-to-topic in that case)
Closed, DuplicatePublic

Description

Take the simple case of a Flow page with a single topic and just its original comment. At the bottom of the page, there is a small/faint "Reply" link, and then below it is a large/prominent "Reply to xxx" box. At least twice, I have been lured in by the big box, and only after hitting the big green Reply button to submit it, I have realized that I should have actually pressed the stealth Reply link.

The result is that people who meant to reply to a specific comment are often going to create a new top-level comment for that topic.

I think the two replies should be equally emphasized, and/or should be much more clearly labeled, so the user can make an informed decision, and hopefully can choose the right one.

Event Timeline

ksmith raised the priority of this task from to Needs Triage.
ksmith updated the task description. (Show Details)
ksmith added a subscriber: ksmith.
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

The input box that is shown by default and the bottom-most reply link have the exact same effect. If you click the bottom-most reply link, it just focuses/expands that input box.

@Mattflaschen: Oh. Thanks for pointing that out. Then I guess my real complaint is that there is literally no way to reply to the last comment on the page. The current UI allows replying specifically to any OTHER comment on the page, but not the last one.

Is that accurate?

Mattflaschen-WMF closed this task as Invalid.Oct 28 2015, 11:49 PM
Mattflaschen-WMF claimed this task.

@Mattflaschen: Oh. Thanks for pointing that out. Then I guess my real complaint is that there is literally no way to reply to the last comment on the page. The current UI allows replying specifically to any OTHER comment on the page, but not the last one.
Is that accurate?

Partly, but not completely. I'll explain visually (how it's stored internally is a different matter).

  • If you reply to a topic, it goes vertically below the last top-level post.
  • If you reply to the last post in a line at a particular depth (last post of a "tangent"), it goes vertically below that post.
  • If you reply to any other post, it creates a new level of diagonal indentation depth.

See first four bullet points at T92400: S3. Deploy new Flow indentation model on Mediawiki.

@Mattflaschen: It seems that T92400 was implemented, despite being counter-intuitive. To make sure we're saying the same thing, if there is:

Topic

  • Reply A

then hitting reply for "Reply A" will (currently) create this:

Topic

  • Reply A
  • My new reply

But what I really wanted, and what I would think most users would expect, was this:

Topic

  • Reply A
    • My new reply

As far as I can tell, there is no way to create a new reply nested inside Reply A. According to T92400, that is intentional, although I don't see any explanation for why it would be desired. The current behavior seems counter-intuitive, and it is quite frustrating that there is literally no way to accomplish something that seems entirely sensible.

ksmith reopened this task as Open.Nov 2 2015, 5:38 PM

Reopening, pending clarifications of my last comment (question). I'm also going to retitle it to reflect my improved understanding of the situation.

I'm pretty sure that my problem report is real, so if anything it should be "declined", rather than marked "invalid". Unless I'm actually mistaken about its current behavior.

ksmith renamed this task from Flow UI encourages reply-to-topic and discourages reply-to-comment to Flow UI does not allow replying to the last comment (it only allows reply-to-topic in that case).Nov 2 2015, 5:39 PM
ksmith set Security to None.

This has been discussed a lot, so I merged this into an older bug.

This was a deliberate product change (led by Danny), and all of the behavior is by-design.

I don't know of any plans to revisit it. It's not impossible to change our mind on this, but we have a lot of other things on our roadmap (also, we only have a part-time on-loan PM right now).

Thanks @Mattflaschen. The ticket you merged this with explains the situation much better than the other ticket(s). While I might agree or disagree with the philosophy, at least now I understand it, and can live with it. For anyone looking at this who doesn't want to click over there, the summary that helped me was when @DannyH wrote:

The core idea is that you should be able to follow the general flow of conversation down the left side of the thread, and most simple conversations between two or three people will look flat. The indentation is a special feature that happens when somebody goes back in the chronology and creates a tangent based on an earlier post, instead of following the conversational flow.

"Mattflaschen closed this task as a duplicate of T93883: ..." - that page is not specifically about impossibility to reply to latest comment, but one example, of bug report author, @He7d3r , maybe, also/partially says about that: "This was a reply to Leonardo, not to the IP itself: https://pt.wikipedia.org/w/index.php?title=T%C3%B3pico:Sghi15zkgzpkazhj&topic_showPostId=sghjjxakzxss4ydh#flow-post-sghjjxakzxss4ydh".

i know bug reports and feature requests exactly about replying to last comment: earliest is T94381 , it has another 2 duplicates T102650 , T95084 , and, this.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptFeb 6 2016, 5:24 PM
DannyH removed a subscriber: DannyH.Feb 8 2016, 7:22 PM